Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 820454 - Installation of new kernel via yum ignores entry in /etc/default/grub and in /etc/sysconfig/kernel to not update default boot
Summary: Installation of new kernel via yum ignores entry in /etc/default/grub and in ...
Keywords:
Status: CLOSED DUPLICATE of bug 768106
Alias: None
Product: Fedora
Classification: Fedora
Component: grubby
Version: 16
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-10 00:46 UTC by Sergio Monteiro Basto
Modified: 2012-05-14 11:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 808821
Environment:
Last Closed: 2012-05-14 11:45:06 UTC


Attachments (Terms of Use)
/etc/default/grub (deleted)
2012-05-10 00:46 UTC, Sergio Monteiro Basto
no flags Details
grub.cfg before yum update (deleted)
2012-05-10 01:00 UTC, Sergio Monteiro Basto
no flags Details
grub.cfg after yum update (deleted)
2012-05-10 01:02 UTC, Sergio Monteiro Basto
no flags Details

Description Sergio Monteiro Basto 2012-05-10 00:46:58 UTC
Created attachment 583403 [details]
/etc/default/grub

+++ This bug was initially created as a clone of Bug #808821 +++

Description of problem:
I have the following entry in /etc/default/grub
GRUB_DEFAULT="WindowsXP" (without any space)
But when a new kernel is installed via yum this new kernel is made the default.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set GRUB_DEFAULT to some particular kernel or other entry
2. Install another kernel via yum
  
Actual results:
The new installed kernel is made the default in Grub

Expected results:
The default boot option should be what was set in GRUB_DEFAULT

Comment 1 Mads Kiilerich 2012-05-10 01:00:09 UTC
/etc/default/grub is _only_ used when grub2-mkconfig is run. That will not happen when new kernels are installed.

grubby is responsible for patching grub.cfg when new kernels are installed. There are known bugs that do that it might change the default boot target in unfortunate ways. This bug is probably a duplicate of an existing bug, but for now I will just reassign to grubby.

Comment 2 Sergio Monteiro Basto 2012-05-10 01:00:54 UTC
Created attachment 583405 [details]
grub.cfg before yum update

Comment 3 Sergio Monteiro Basto 2012-05-10 01:02:13 UTC
Created attachment 583406 [details]
grub.cfg after yum update

Comment 4 Sergio Monteiro Basto 2012-05-10 01:11:07 UTC
(In reply to comment #1)
> /etc/default/grub is _only_ used when grub2-mkconfig is run. That will not
> happen when new kernels are installed.
> 
> grubby is responsible for patching grub.cfg when new kernels are installed.
> There are known bugs that do that it might change the default boot target in
> unfortunate ways. This bug is probably a duplicate of an existing bug, but for
> now I will just reassign to grubby.

where grubby reads the defaults ? 
also doesn't read /etc/sysconfig/kernel

Comment 5 Mads Kiilerich 2012-05-10 01:41:14 UTC
"Grubby" do read /etc/sysconfig/kernel for some purposes, and /usr/sbin/grubby try to read and understand the boot loader file and patch it correctly.

Comment 6 Sergio Monteiro Basto 2012-05-13 21:04:16 UTC
this in a side effect of bug 768106 , which grubbt replace my default entry with "0"

I will study bug 768106 to understand if I got a better work around than edit grub.cfg, after every kernel update.

Comment 7 Mads Kiilerich 2012-05-14 11:45:06 UTC

*** This bug has been marked as a duplicate of bug 768106 ***


Note You need to log in before you can comment on or make changes to this bug.