Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82044 - Last Errata overwrote system wide config file
Summary: Last Errata overwrote system wide config file
Keywords:
Status: CLOSED DUPLICATE of bug 82037
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-16 18:33 UTC by Manfred Hollstein
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:12 UTC


Attachments (Terms of Use)

Description Manfred Hollstein 2003-01-16 18:33:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021203

Description of problem:
Installing the recently released errata packages for vim, overwrote
the system wide config file /usr/share/vim/vim61/macros/vimrc without
any notice.

Version-Release number of selected component (if applicable):
-6.1-18.8x.1

How reproducible:
Always

Steps to Reproduce:
1.Make mods to /usr/share/vim/vim61/macros/vimrc and save them
2.rpm -Uvh vim*-6.1-18.8x.1*.rpm
3.Look for your modifications in /usr/share/vim/vim61/macros/vimrc
  and see how they have been wiped out :-(
    

Actual Results:  Config file will be silently overwritten, no vimrc.rpmsave is
created.

Expected Results:  The file should have been installed either as
/usr/share/vim/vim61/macros/vimrc.rpmnew, or the existing one should
have been renamed to /usr/share/vim/vim61/macros/vimrc.rpmsave

Additional info:  FWIW, the man page talks about /usr/share/vim/vimrc being
the system wide config file, but strace'ing vim shows that that's not the case;
so, the man page needs update'ing, too.

Comment 1 Karsten Hopp 2003-01-16 18:46:08 UTC

*** This bug has been marked as a duplicate of 82037 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.