Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82034 - gone - no logout
Summary: gone - no logout
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-16 16:55 UTC by Per Starbäck
Modified: 2007-04-18 16:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-03 19:59:41 UTC


Attachments (Terms of Use)

Description Per Starbäck 2003-01-16 16:55:31 UTC
Description of problem:


Version-Release number of selected component (if applicable):

XFree86-4.2.0-8 (which I guess is the right component, since it contains
sessreg)
gdm-2.2.3.1-22

How reproducible:
Always.

Steps to Reproduce:
1.Log in with gdm
2.Run "last"
     
Actual results:

It says

uname     :0                            Thu Jan 16 17:05    gone - no logout 

even though I'm still logged in.
    
Expected results:

I expected "still logged in" as I get when I login from a console.

Comment 1 Per Starbäck 2003-01-22 18:43:07 UTC
Now I think the problem is in gdm.
last says "no logout" because the ut_pid process in wtmp doesn't exist any longer.
sessreg puts the parent process in ut_pid which won't be the right process
when sessreg is done in /etc/X11/gdm/PreSession/Default.


Comment 2 Mike A. Harris 2003-01-24 06:08:54 UTC
Adding GNOME guys to CC for comment.

Comment 3 Havoc Pennington 2003-01-24 06:29:48 UTC
You can't NEEDINFO unless you ask a question. ;-)
I would have to investigate, same as anyone else.
I'll cc more people in case they have ideas but basically 
we have to debug the problem.

Comment 4 Mike A. Harris 2003-01-24 07:06:21 UTC
Ok, reassigning to gdm for now as it seems more of a gdm issue from
the above info.

Comment 5 George Lebl 2003-01-24 17:03:31 UTC
This is a problem in the /etc/X11/gdm/PreSession/Default file.  Make sure that
the line that runs sessreg has an exec in it.  As far as I can see this is fixed
in rh8.  Also the default script in the distro fixes this.

Comment 6 Havoc Pennington 2003-02-03 19:59:41 UTC
Ah, this is reported for 7.3. Should be fixed in 8.


Note You need to log in before you can comment on or make changes to this bug.