Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 820299 - Communication with server receives some unknown errors.
Summary: Communication with server receives some unknown errors.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: TCMS
Classification: Other
Component: Usability
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.7.0
Assignee: June Zhang
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks: 593666
TreeView+ depends on / blocked
 
Reported: 2012-05-09 14:44 UTC by Petr Sklenar
Modified: 2012-05-11 07:04 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-11 05:53:40 UTC


Attachments (Terms of Use)
Still fails - error returned after trying to edit a test case (deleted)
2012-05-10 15:09 UTC, David Spalding
no flags Details

Description Petr Sklenar 2012-05-09 14:44:24 UTC
Description of problem:
I filled ticket but it looks like bug in tcms:

ticket was:
[engineering.redhat.com #152653] AutoReply: tcms: Commnucation with server got some unknown errors.
to be sure writing to this list:

Version-Release number of selected component (if applicable):
Nitrate 3.7.0 

How reproducible:
deterministic

Steps to Reproduce:
1, looking at https://tcms.engineering.redhat.com/run/38090/#caserun_1090524

waiting waiting waiting ...
Commnucation with server got some unknown errors.

opening whatever case, then I can see:

    Sorry, This is a service error.
    1.Please check your operation , try it again;
    2.You can contact the administrator or developer.
    GO BACK

# date
Wed May  9 09:03:18 EDT 2012

xmlrpc says:
xmlrpclib.Fault: <Fault 1: 'DatabaseError: (1146, "Table \'testopia.tcms_linkrefs\' doesn\'t exist")'>

  
Actual results:
data lost?

xmlrpc says:
xmlrpclib.Fault: <Fault 1: 'DatabaseError: (1146, "Table \'testopia.tcms_linkrefs\' doesn\'t exist")'>


webUI says
    Sorry, This is a service error.
    1.Please check your operation , try it again;
    2.You can contact the administrator or developer.
    GO BACK



Expected results:
no fail, no data lost
I can see my test case results

Additional info:
ticket
[engineering.redhat.com #152653]

Comment 1 Ales Zelinka 2012-05-09 16:36:23 UTC
This affects all test-case-runs in all test-runs I've tried. We can't use TCMS at all. Please hotfix TCMS as soon as possible. 

Thanks in advance

Comment 2 David Spalding 2012-05-09 22:09:27 UTC
I can't edit any test cases after creation, also can't edit cloned cases. 

This will cause a significant block for pre-R12 planning and execution. 

Adding my voice ... please investigate and resolve ASAP. 

https://tcms.engineering.redhat.com/case/166636/?from_plan=5855

https://tcms.engineering.redhat.com/case/166633/?from_plan=5855
https://tcms.engineering.redhat.com/case/166634/?from_plan=5855
https://tcms.engineering.redhat.com/case/166635/?from_plan=5855

https://tcms.engineering.redhat.com/case/166632/edit/?from_plan= generates
the 500 error.

Comment 3 Victor Chen 2012-05-10 03:05:23 UTC
The problem was caused by a missing step during upgrade, recovered.

Comment 4 Ales Zelinka 2012-05-10 08:48:03 UTC
I can open test-case-runs again. Thank you for the quick fix.

Comment 5 Petr Sklenar 2012-05-10 09:12:45 UTC
hello much better, thanks for the fix.

But there is some minor issue.

Look at below of the page:
https://tcms.engineering.redhat.com/run/36600/
https://tcms.engineering.redhat.com/run/38469/
https://tcms.engineering.redhat.com/run/35561/

there are error at the bottom of the page:
All these fields are required.
Name * (64 characters at most) URL *

--
have no idea what's expecting to be there

Comment 6 David Spalding 2012-05-10 13:31:03 UTC
(In reply to comment #3)
> The problem was caused by a missing step during upgrade, recovered.

Can we add some basic validation into the upgrade procedure, to prevent future 
calamities? 


(In reply to comment #5)
> 
> But there is some minor issue.
> 
> Look at below of the page:
> https://tcms.engineering.redhat.com/run/36600/
> https://tcms.engineering.redhat.com/run/38469/
> https://tcms.engineering.redhat.com/run/35561/
> 
> there are error at the bottom of the page:
> All these fields are required.
> Name * (64 characters at most) URL *
> 
> --
> have no idea what's expecting to be there

I don't see the errors on those runs at this time.

Comment 7 David Spalding 2012-05-10 15:09:11 UTC
Created attachment 583607 [details]
Still fails - error returned after trying to edit a test case

I can create and save a new test case, but "Save and Continue editing" results in the error (attached). I've tried with test cases previously authored, and new test cases:



https://tcms.engineering.redhat.com/case/166686/?from_plan=5855
https://tcms.engineering.redhat.com/case/166687/?from_plan=5855

Comment 8 Martin Cermak 2012-05-10 16:26:40 UTC
I can confirm testcases are still not editable at this moment. This is important, please, have a look at it soon. Thanks.

Comment 9 jianchen 2012-05-11 05:53:40 UTC
This bug was Fixed.
This bug raised because tcms-3.7.0's deploy steps . 
I sincerely apologize for this bug.


Note You need to log in before you can comment on or make changes to this bug.