Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 820248 - Start using glassfish-jsp
Summary: Start using glassfish-jsp
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krzysztof Daniel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-09 13:15 UTC by Alexander Kurtakov
Modified: 2014-01-13 00:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-31 09:06:33 UTC


Attachments (Terms of Use)

Description Alexander Kurtakov 2012-05-09 13:15:22 UTC
Jetty is using glassfish-jsp so eclipse should be changed to use it too as we have jsp apis in just for jetty(help center). Also this should allow us to not have any dependency on tomcat directly in eclipse.
Another thing is that this breaks the loop between ecj and tomcat and we should be able to move jdt.core into jdt where it belongs. But this should be done with extra care as the opposite move in Fedora 16 broke too many installations.

Comment 1 Krzysztof Daniel 2012-05-10 07:49:51 UTC
I'd like to target it too f18 - after, or maybe together, with CBI build. I do not see much sense in working on this in current release.

Comment 2 Krzysztof Daniel 2012-08-29 13:18:03 UTC
Now it's time for this.


Note You need to log in before you can comment on or make changes to this bug.