Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 820111 - System list: item count is wrong, paging is broken
Summary: System list: item count is wrong, paging is broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: inventory
Version: 0.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 0.9.0
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
: 819921 824453 832523 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-09 07:59 UTC by Raymond Mancy
Modified: 2014-12-08 01:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-26 06:41:05 UTC


Attachments (Terms of Use)

Description Raymond Mancy 2012-05-09 07:59:42 UTC
Description of problem:

System search sometimes returns the wrong item count, and random paging results

Version-Release number of selected component (if applicable):

0.8.2

How reproducible:

Everytime

Steps to Reproduce:
1. Search Systems by the following
Core > 4
Mem > 4096
User = ""
Status = "Automated"
Key/Value HVM = 1



  
Actual results:

Some large item count and weird paging

Expected results:

Correct item count and normal paging

Additional info:

This is probably the same bug as 769286

Comment 1 Raymond Mancy 2012-05-10 12:01:29 UTC
The problem is because of 1:N relationships of Systems to some other tables (KeyValue in this case). The keeping it simple solution is to issue a distinct on the query

Comment 2 Raymond Mancy 2012-05-10 14:09:49 UTC
On gerrit for review
http://gerrit.beaker-project.org/#/c/1052/

Comment 3 Raymond Mancy 2012-05-10 15:06:36 UTC
*** Bug 819921 has been marked as a duplicate of this bug. ***

Comment 4 Dan Callaghan 2012-05-23 22:28:53 UTC
*** Bug 824453 has been marked as a duplicate of this bug. ***

Comment 6 Dan Callaghan 2012-06-19 02:46:30 UTC
*** Bug 832523 has been marked as a duplicate of this bug. ***

Comment 7 Dan Callaghan 2012-06-26 06:41:05 UTC
Beaker 0.9.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.