Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82007 - crash on upgrade to mysql-server-3.23.54a-3.72
Summary: crash on upgrade to mysql-server-3.23.54a-3.72
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql
Version: 7.2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-16 10:05 UTC by Ilja Booij
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 16:23:08 UTC


Attachments (Terms of Use)

Description Ilja Booij 2003-01-16 10:05:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After an up2date upgrade, client programs were not able to connect to the
mysql-server. This happened on two machines (both running RedHat Linux 7.2) at
the same time. After manually killing all mysql processes (the
/etc/init.d/mysqld script could not stop them, because
/var/run/mysqld/mysqld.pid was non-existant) mysqld could be started again, and
is functioning now (20 minutes later).


Version-Release number of selected component (if applicable): 3.23.54a-3.72


How reproducible:
Didn't try


Additional info:

Before restarting mysqld, the 'top' command did not function, but returned a
'floating point exception'. The 'ps' command did function, so I could verify
that mysqld was indeed running. When mysql is running again, 'top' also works.

Comment 1 Patrick Macdonald 2003-02-19 16:23:08 UTC
Ok... tested this.  I shut down the mysqld service, did an up2date on my 7.2
machine, restarted the mysqld service and all ran fine.  My mysql clients
were able to connect and extract data from the database.  There was no problem
with top either.


Note You need to log in before you can comment on or make changes to this bug.