Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 819923 - SELinux is preventing restorecond from 'getattr' accesses on the filesystem /proc.
Summary: SELinux is preventing restorecond from 'getattr' accesses on the filesystem /...
Keywords:
Status: CLOSED DUPLICATE of bug 819927
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:be4105396350b6607a22339599b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-08 16:00 UTC by Frank Murphy
Modified: 2012-05-08 16:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-08 16:27:51 UTC


Attachments (Terms of Use)

Description Frank Murphy 2012-05-08 16:00:21 UTC
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-5.fc17.i686
time:           Tue 08 May 2012 16:59:45 IST

description:
:SELinux is preventing restorecond from 'getattr' accesses on the filesystem /proc.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that restorecond should be allowed getattr access on the proc filesystem by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep restorecond /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:restorecond_t:s0
:Target Context                system_u:object_r:proc_t:s0
:Target Objects                /proc [ filesystem ]
:Source                        restorecond
:Source Path                   restorecond
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           filesystem-3-2.fc17.i686
:Policy RPM                    selinux-policy-3.10.0-121.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-5.fc17.i686 #1
:                              SMP Mon May 7 17:45:26 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Tue 08 May 2012 16:57:33 IST
:Last Seen                     Tue 08 May 2012 16:57:33 IST
:Local ID                      3b488ce0-034a-462d-b333-360bd1402d6c
:
:Raw Audit Messages
:type=AVC msg=audit(1336492653.513:83): avc:  denied  { getattr } for  pid=2227 comm="restorecond" name="/" dev="proc" ino=1 scontext=system_u:system_r:restorecond_t:s0 tcontext=system_u:object_r:proc_t:s0 tclass=filesystem
:
:
:Hash: restorecond,restorecond_t,proc_t,filesystem,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:

Comment 1 Daniel Walsh 2012-05-08 16:27:51 UTC

*** This bug has been marked as a duplicate of bug 819927 ***


Note You need to log in before you can comment on or make changes to this bug.