Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 819907 - "Missing template deployables/show with {:handlers=>[:builder, :rjs, :haml, :rhtml, :erb, :rxml], :locale=>[:en, :en], :formats=>[:json, :js, "*/*"]}" error thrown when blueprint that includes an image that no longer exists
Summary: "Missing template deployables/show with {:handlers=>[:builder, :rjs, :haml, ...
Keywords:
Status: CLOSED DUPLICATE of bug 809722
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.1.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
Assignee: Angus Thomas
QA Contact: Rehana
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-08 15:19 UTC by Ronelle Landy
Modified: 2012-05-08 15:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-08 15:50:42 UTC


Attachments (Terms of Use)
screenshot of Missing Template error (deleted)
2012-05-08 15:35 UTC, Ronelle Landy
no flags Details

Description Ronelle Landy 2012-05-08 15:19:52 UTC
Description of problem:

Not sure how reproducible this is. I saw this happen twice while testing roles and permissions. 

If a user uploads a  blueprint that includes an image that no longer exists (has since been deleted), and then the user navigates away from that blueprint to conductor/images to update the image, the following error is visible in Conductor: 

"Missing template deployables/show with {:handlers=>[:builder, :rjs,  :haml, :rhtml, :erb,  :rxml], :locale=>[:en, :en],  :formats=>[:json, :js, "*/*"]} in view paths  "/usr/share/aeolus-conductor/app/views" 


Steps to Reproduce:
1. Upload a saved xml blueprint file that contains an image id that has been deleted or is no longer accessible to conductor
2. See the appropriate error message: rhel6: Image (UUID: xxxx) doesn't exist
3. Navigate away from the blueprint page back to the images page to check for available images
4. See the error: "Missing template deployables/show with {:handlers=>[:builder, :rjs,  :haml, :rhtml, :erb,  :rxml], :locale=>[:en, :en],  :formats=>[:json, :js, "*/*"]} in view paths  "/usr/share/aeolus-conductor/app/views" 


Additional info:

Versions tested:

>> rpm -qa | grep aeolus
aeolus-configure-2.5.3-1.el6.noarch
aeolus-all-0.8.13-1.el6_2.noarch
aeolus-conductor-0.8.13-1.el6_2.noarch
aeolus-conductor-daemons-0.8.13-1.el6_2.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-doc-0.8.13-1.el6_2.noarch

Comment 1 Ronelle Landy 2012-05-08 15:35:13 UTC
Created attachment 583021 [details]
screenshot of Missing Template error

Comment 2 Ronelle Landy 2012-05-08 15:38:02 UTC
was able to reproduce this error ( see screenshot above) when the user logged in did not have "Global Application Blueprint Administrator" or "Global Image Administrator" permissions

Comment 3 Dave Johnson 2012-05-08 15:50:42 UTC

*** This bug has been marked as a duplicate of bug 809722 ***


Note You need to log in before you can comment on or make changes to this bug.