Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 819840 - [abrt] yum-3.4.3-23.fc16: yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for google-chrome
Summary: [abrt] yum-3.4.3-23.fc16: yumRepo.py:999:_cachingRepoXML:RepoError: Cannot fi...
Keywords:
Status: CLOSED DUPLICATE of bug 809469
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Packaging Toolset Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4829d46802512036205cc877f2d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-08 10:50 UTC by totoleor
Modified: 2014-01-21 23:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-09 09:15:24 UTC


Attachments (Terms of Use)
File: event_log (deleted)
2012-05-08 10:50 UTC, totoleor
no flags Details
File: smolt_data (deleted)
2012-05-08 10:50 UTC, totoleor
no flags Details

Description totoleor 2012-05-08 10:50:44 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available python-mut
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.2-6.fc16.i686
reason:         yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for google-chrome
reported_to:    file: /tmp/abrt.log
time:           2012年05月08日 星期二 18时31分33秒
uid:            1000
username:       ray

event_log:      Binary file, 275 bytes
smolt_data:     Binary file, 3183 bytes

backtrace:
:yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for google-chrome
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 81, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 77, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 44, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2660, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1003, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 767, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 294, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 167, in populate
:    if self._check_db_version(repo, mydbtype):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 225, in _check_db_version
:    return repo._check_db_version(mdtype)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1272, in _check_db_version
:    repoXML = self.repoXML
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1466, in <lambda>
:    repoXML = property(fget=lambda self: self._getRepoXML(),
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1462, in _getRepoXML
:    self._loadRepoXML(text=self)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1453, in _loadRepoXML
:    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1428, in _groupLoadRepoXML
:    if self._commonLoadRepoXML(text):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1233, in _commonLoadRepoXML
:    if self._cachingRepoXML(local):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 999, in _cachingRepoXML
:    raise Errors.RepoError, 'Cannot find repomd.xml file for %s' % self
:RepoError: Cannot find repomd.xml file for google-chrome
:
:Local variables in innermost frame:
:self: <yum.yumRepo.YumRepository object at 0xb70fbc6c>
:local: '/var/tmp/yum-ray-lVtGBy/i386/16/google-chrome/repomd.xml'

Comment 1 totoleor 2012-05-08 10:50:49 UTC
Created attachment 582959 [details]
File: event_log

Comment 2 totoleor 2012-05-08 10:50:51 UTC
Created attachment 582960 [details]
File: smolt_data

Comment 3 Zdeněk Pavlas 2012-05-09 09:15:24 UTC

*** This bug has been marked as a duplicate of bug 809469 ***


Note You need to log in before you can comment on or make changes to this bug.