Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81958 - changing $0 / $PROGRAM_NAME has no effect
Summary: changing $0 / $PROGRAM_NAME has no effect
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-15 19:36 UTC by Jonathan Schatz
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-04-22 14:45:43 UTC


Attachments (Terms of Use)
a small test case for this bug (deleted)
2003-01-15 19:37 UTC, Jonathan Schatz
no flags Details

Description Jonathan Schatz 2003-01-15 19:36:28 UTC
Description of problem:
assigning a value to $0 or $PROGRAM_NAME has no effect

Version-Release number of selected component (if applicable):

[jon@jonschatz-lx jon]$ rpm -q perl
perl-5.8.0-55


How reproducible:
every time.

Steps to Reproduce:

run the test case i'll attach after i submit this.

Actual results:
the test case fails.

Expected results:
the test case should pass.

Additional info:

Comment 1 Jonathan Schatz 2003-01-15 19:37:53 UTC
Created attachment 89385 [details]
a small test case for this bug

this fails with assigning to $0 and with $PROGRAM_NAME. comment out one or the
other to see it fail with either.

Comment 2 Jonathan Schatz 2003-08-28 00:08:44 UTC
this seems to be fixed in rh9.0 with:

[jon@jonschatz-lx jon]$ rpm -q perl
perl-5.8.0-88




Note You need to log in before you can comment on or make changes to this bug.