Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 819515 - [abrt] picard-0.16-1.fc16: script.py:105:__raise_eof:EndOfFile: Unexpected end of script at position 105, line 1
Summary: [abrt] picard-0.16-1.fc16: script.py:105:__raise_eof:EndOfFile: Unexpected en...
Keywords:
Status: CLOSED DUPLICATE of bug 768781
Alias: None
Product: Fedora
Classification: Fedora
Component: picard
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1e46272fa2838d3f534ccc498b3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-07 13:15 UTC by Lionel Félicité
Modified: 2012-05-08 18:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-08 18:54:04 UTC


Attachments (Terms of Use)

Description Lionel Félicité 2012-05-07 13:15:14 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/picard
executable:     /usr/bin/picard
kernel:         3.3.4-3.fc16.x86_64
reason:         script.py:105:__raise_eof:EndOfFile: Unexpected end of script at position 105, line 1
time:           lun. 07 mai 2012 15:14:53 CEST
uid:            500
username:       lfelicite

backtrace:
:script.py:105:__raise_eof:EndOfFile: Unexpected end of script at position 105, line 1
:
:Traceback (most recent call last):
:  File "/usr/lib64/python2.7/site-packages/picard/ui/options/renaming.py", line 71, in check_formats
:    self.update_examples()
:  File "/usr/lib64/python2.7/site-packages/picard/ui/options/renaming.py", line 98, in update_examples
:    example1 = self._example_to_filename(self.example_1())
:  File "/usr/lib64/python2.7/site-packages/picard/ui/options/renaming.py", line 89, in _example_to_filename
:    filename = file._make_filename(file.filename, file.metadata, settings)
:  File "/usr/lib64/python2.7/site-packages/picard/file.py", line 229, in _make_filename
:    new_filename = self._script_to_filename(format, metadata, settings)
:  File "/usr/lib64/python2.7/site-packages/picard/file.py", line 202, in _script_to_filename
:    filename = ScriptParser().eval(format, metadata, self)
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 236, in eval
:    ScriptParser._cache[key] = self.parse(script, True)
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 227, in parse
:    return self.parse_expression(True)[0]
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 205, in parse_expression
:    tokens.append(self.parse_function())
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 151, in parse_function
:    return ScriptFunction(name, self.parse_arguments())
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 138, in parse_arguments
:    result, ch = self.parse_expression(False)
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 201, in parse_expression
:    self.__raise_eof()
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 105, in __raise_eof
:    raise EndOfFile("Unexpected end of script at position %d, line %d" % (self._x, self._y))
:EndOfFile: Unexpected end of script at position 105, line 1
:
:Local variables in innermost frame:
:self: <picard.script.ScriptParser object at 0x2b6b910>

Comment 1 Alex Lancaster 2012-05-08 18:49:27 UTC
Can you describe exactly the set of steps you used to reproduce this?  If it's
a problem with a particular file, can you post a link to the file (or an
extract)?

Comment 2 Alex Lancaster 2012-05-08 18:54:04 UTC
This looks to be a duplicate of bug #768781 (crash happens at the same line in both bugs).  Please follow up on my request in comment #1 on the bug #768781 if you're still having problems.

*** This bug has been marked as a duplicate of bug 768781 ***


Note You need to log in before you can comment on or make changes to this bug.