Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 819509 - gnome-system-log fails to run
Summary: gnome-system-log fails to run
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-system-log
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-07 13:01 UTC by Przemek Klosowski
Modified: 2012-05-19 01:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-19 01:56:51 UTC


Attachments (Terms of Use)

Description Przemek Klosowski 2012-05-07 13:01:28 UTC
Description of problem:
gnome-system-log fails to display anything, disappears without a trace.


Version-Release number of selected component (if applicable):
gnome-system-log-3.4.1-2.fc17.x86_64


How reproducible: every time


Steps to Reproduce:
1. run gnome-system-log from menus or command line
2. see nothing

  
Actual results:
When ran from Applications/System Tools/Log File Viewer menu, it shows 'Starting Log File Viewer' icon in the bottom bar for about 10 seconds, and disappears, without opening any windows. 

When run from the root shell prompt, it prints the message:

(logview:13781): gnome-system-log-CRITICAL **: Unable to parse arguments: Cannot open display: 

It is not a $DISPLAY problem because e.g. gnome-system-monitor command works fine (opens the monitor window, etc).
 

Expected results:
I believe that a window should appear displaying the system logs 


Additional info:

Comment 1 antonio montagnani 2012-05-07 13:29:26 UTC
if you open a terminal and you become root by su, then issue gnome-system-monitor, it works

Comment 2 Przemek Klosowski 2012-05-07 18:01:09 UTC
(In reply to comment #1)
> if you open a terminal and you become root by su, then issue
> gnome-system-monitor, it works

Yes, that's what I reported: gnome-system-monitor works but gnome-system-log (which is what this bug report is about) doesn't:

[root@przemek przemek]# gnome-system-log
  (logview:4748): gnome-system-log-CRITICAL **: Unable to parse arguments: Cannot 
  open display: 
  <immediately returns to shell prompt...>
[root@przemek przemek]# gnome-system-monitor 
  <shows correct monitor window and works, in general>
[root@przemek przemek]#

Comment 3 Matthias Clasen 2012-05-07 18:16:28 UTC
what kind of desktop environment is this running in ?
do you get a password prompt when running gnome-system-log as regular user ?
do you have /usr/share/polkit-1/actions/org.gnome.logview.policy ?
does "pkexec sh" bring up a password dialog ?

Comment 4 antonio montagnani 2012-05-07 18:58:00 UTC
it had to be read as gnome-system-log

Running Gnome
Yes I get passwd prompt
Yes I have /usr/share/polkit-1/actions/org.gnome.logview.policy
Yes pkexec sh brings up a password dialog

Same on fresh installation and upgraded installation

Comment 5 antonio montagnani 2012-05-07 19:04:30 UTC
it had to be read as gnome-system-log

Running Gnome
Yes I get passwd prompt
Yes I have /usr/share/polkit-1/actions/org.gnome.logview.policy
Yes pkexec sh brings up a password dialog

Same on fresh installation and upgraded installation

Comment 6 Przemek Klosowski 2012-05-07 21:03:42 UTC
(In reply to comment #3)
> what kind of desktop environment is this running in ?
Gnome

> do you get a password prompt when running gnome-system-log as regular user ?
Yes, and after authentication it actually runs!!!!!!!!!!!!!!!!
still, doesn't work off the menu or from the root shell.

> do you have /usr/share/polkit-1/actions/org.gnome.logview.policy ?
Yes, it is owned by gnome-system-log-3.4.1-2.fc17.x86_64 and rpm --verify confirms it's unchanged (only /usr/bin/logview is changed due to prelinking)

> does "pkexec sh" bring up a password dialog ?
Yes, and when I give the user password, it runs the root shell for me.

Comment 7 Matthias Clasen 2012-05-19 01:56:51 UTC
This was tracked down to a problem with the way gnome-shell launches applications:
http://git.gnome.org/browse/gnome-shell/commit/?id=02e4726ba62659b4cdeca5274d76ba8f14edb768

Will be fixed in the next gnome-shell release.


Note You need to log in before you can comment on or make changes to this bug.