Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81949 - workspace switching does not cycle
Summary: workspace switching does not cycle
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: metacity
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-15 17:41 UTC by Sam Steingold
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-15 22:55:43 UTC


Attachments (Terms of Use)

Description Sam Steingold 2003-01-15 17:41:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
workspace switching does not cycle between the workspaces any longer.
it did in rh8.

suppose you have 4 workspaces located as follows

   1   2
   3   4

if you start with workspace <1> and hit C-S-A-<left>, you should go to <4>, then
<3>, then <2>, then <1> - this is what happened in rh8.

now you just stay in <1>.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.go to workspace1
2.hit Ctrl-Alt-Shift-Left

    

Actual Results:  nothing happens

Expected Results:  you switch to workspace4

Additional info:

doing nothing in response to a user action is no good.
it was better before when I could go from any workspace to any other workspace
in a single keystroke.

Comment 1 Havoc Pennington 2003-01-15 17:52:49 UTC
Done on purpose, for consistency with similar UI in other places, and so you can 
"slam" to one side.

To move to any space with a single keystroke I personally use keybindings 
such as Alt+1, Alt+2, Alt+3, etc. for specific spaces.

Anyway, if you want to read more text on this topic there are bugs 
on bugzilla.gnome.org that go on forever.

Comment 2 Sam Steingold 2003-01-15 18:07:40 UTC
this is NOT consistent because C-M-RIGHT on workspace<2>
DOES switch to workspace<3>.
if you want it to be consistent, you have to disable that too.

Comment 3 Havoc Pennington 2003-01-15 19:37:00 UTC
Are you using metacity 2.4.13 from rawhide? That issue should be fixed in 2.4.13.

Comment 4 Sam Steingold 2003-01-15 22:48:34 UTC
I am using phoebe, not rawhide.
I upgraded metacity to  2.4.13 and indeed that fixed the bug.
thanks.

Comment 5 Havoc Pennington 2003-01-15 22:55:43 UTC
thanks for testing


Note You need to log in before you can comment on or make changes to this bug.