Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 819348 - Clickpad generates mouse movement on "SoftButtonAreas"
Summary: Clickpad generates mouse movement on "SoftButtonAreas"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics
Version: 17
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-06 19:44 UTC by Kazimieras Vaina
Modified: 2013-12-27 01:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-07 02:39:48 UTC


Attachments (Terms of Use)
Xorg.0.log (deleted)
2012-05-08 16:47 UTC, Kazimieras Vaina
no flags Details

Description Kazimieras Vaina 2012-05-06 19:44:07 UTC
Description of problem:
Synaptics clickpad generates mouse movement events in the soft button area even there is more than one button configured.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-1.6.0-1

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora 17 Beta on HP probook 4520s
2.Configure clickpad to have 3-buttons 
3.Attempt to do DND using the clickpad.
  
Actual results:
When the finger pressing the button area moves a bit, the DND is aborted with unpredictable results.

Expected results:
The DND does not end until the button area is not released. Mouse clicks are accurate - mouse position is not affected when pressing clickpad button area.

Additional info:
I managed to get 3 clickpad buttons working with the following configuration:
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "3872 5671 3984 7694 3272 3871 3984 7694"
EndSection

However when I press the button area the mouse pointer slightly moves and sometimes miss the GUI control I wanted to trigger. The DND is even harder.

I suggest to disable mouse movement in soft button area of the clickpad or make it somehow configurable.
I tried the "AreaBottomEdge" option, but that makes only one button working.

Comment 1 Peter Hutterer 2012-05-07 21:42:40 UTC
can I have your Xorg.log please?

Comment 2 Kazimieras Vaina 2012-05-08 16:47:44 UTC
Created attachment 583044 [details]
Xorg.0.log

Comment 3 Peter Hutterer 2012-05-09 02:05:09 UTC
what I can reproduce here is that if I move my finger to the right, the context menu will pop up eventually (i.e. the driver sends a btn3 event). same with the middle button, but I found that harder to hit. Is that what you're seeing?

Comment 4 Kazimieras Vaina 2012-05-09 16:46:07 UTC
well, I'm not sure. 

I do not use tapping feature, so to generate a mouse click I have to press the "physical" clickpad button. I need to apply some amount of pressure to make a click. When I'm making such click, then the area, that I'm touching with a finger, un-uniformly increases and, I think, that generates a mouse move event before mouse click event (even the finger does not leave soft button area) - which in turn decreases click accuracy. I don't have problem with accidental clicks.

I think the clickpad should not generate mouse move events when I'm sliding a finger through the soft button area. What do you think ?

Comment 5 Fedora Update System 2012-05-11 01:45:09 UTC
xorg-x11-drv-synaptics-1.6.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.1-1.fc17

Comment 6 Kazimieras Vaina 2012-05-11 17:38:56 UTC
I installed updated package from koji and it really improved DND using clickpad. Thank you!
It just didn't help with clicks accuracy.

Comment 7 Fedora Update System 2012-05-11 21:50:59 UTC
Package xorg-x11-drv-synaptics-1.6.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.6.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7703/xorg-x11-drv-synaptics-1.6.1-1.fc17
then log in and leave karma (feedback).

Comment 8 Peter Hutterer 2012-05-13 23:13:10 UTC
I'm not sure how to fix this, tbh. The issue is a bit more complex:

First - I have to rule out not moving the cursor while in the soft button area. On most (if not all) touchpads this area is merely some hinted painting and it's not clear to the user where the movement would stop.

OTOH, detecting if a movement is about to be a click is tricky at best. The pressure grows (on touchpads that have pressure) but detecting that is hard. And since you won't know until you see the click, which may be perceptible after the movement. so we're prone to nonresponsive cursor movements here.

in short, I don't think we can fix this automatically. if it's a big problem for you you can use the Area*Edge options, they should leave the software buttons intact but prohibit cursor movement.

Comment 9 Kazimieras Vaina 2012-05-14 06:53:33 UTC
I see, IMHO to rule out cursor movement is "more" implementable than detecting if a movement is about to be a click. 

It's not a big problem, but it's uncomfortable. I tried setting the AreaBottomEdge option, but then I get only one button and no DND. I will try to configure tapping.

Thank you for the effort.

Comment 10 Peter Bloomfield 2012-05-23 16:42:07 UTC
Just came across this bug after having the cursor jump when I click on a control. I upgraded to the build in comment #7 and it fixed the problem.

ThinkPad T43 with SynPS/2 Synaptics TouchPad

Thanks for all the good work!

Comment 11 Fedora Update System 2012-06-07 02:39:48 UTC
xorg-x11-drv-synaptics-1.6.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Jesús Abelardo Saldívar Aguilar 2013-12-27 01:25:07 UTC
I have the same problem on a Lenovo Ideapad U310, on Fedora 20

Pressing and releasing the clickpad's "click" button generates unwanted cursor movement.

I can make some workarounds adjusting Vertical and Horizontal Hysteresis and AreaBottomEdge, but that generates other problems and doesn't do what I want.

I can use decently this touchpad with tap and double finger tap for left and right clicks respectively, but can't press or release the button without unwanted cursor movement.


Note You need to log in before you can comment on or make changes to this bug.