Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81932 - (NPTL kernel) strange startup glitch with cannaserver
Summary: (NPTL kernel) strange startup glitch with cannaserver
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: Canna
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nakai
QA Contact: Bill Huang
URL:
Whiteboard: qa-i18n
: 82163 83367 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-15 11:48 UTC by Warren Togami
Modified: 2007-04-18 16:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-05 07:50:04 UTC


Attachments (Terms of Use)

Description Warren Togami 2003-01-15 11:48:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
[root@laptop root]# service canna start
Starting cannaserver:                                      [FAILED]

Canna started properly in Phoebe's original kernel-2.4.20-2.2.  However
kernel-2.4.20-2.11 and kernel-2.4.20-2.15 both began to exhibit this behavior. 
If I boot in Psyche's kernel-2.4.18-19.8.0 Canna behaves properly.  (More
details about versions below.)

[root@laptop root]# ps -ef |grep canna |grep -v grep
bin       4431     1  0 01:26 ?        00:00:00 cannaserver -syslog -u bin

Strangely after saying [FAILED] cannaserver is running when you check the
processes.  Testing Japanese character XIM input, input and character conversion
seems to work fully, indicating that Canna is operating properly.

[root@laptop init.d]# cannaserver -syslog -u bin
Terminated
[root@laptop init.d]# echo $?
143
[root@laptop init.d]# ps -ef |grep canna |grep -v grep
bin       4515     1  0 01:31 ?        00:00:00 cannaserver -syslog -u bin

Checking /etc/init.d/canna, the system starts the service with the above
command, but terminates and returns an error code despite the Canna service
starting properly.

[root@laptop init.d]# strace cannaserver -syslog -u bin
execve("/usr/sbin/cannaserver", ["cannaserver", "-syslog", "-u", "bin"], [/* 28
vars */]) = 0
uname({sys="Linux", node="laptop", ...}) = 0
brk(0)                                  = 0x806ec80
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40015000
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=116928, ...}) = 0
old_mmap(NULL, 116928, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40016000
close(3) 
------ SNIP A FEW DOZEN LINES ----------
socket(PF_UNIX, SOCK_STREAM, 0)         = 4
connect(4, {sin_family=AF_UNIX, path="/var/run/.nscd_socket"}, 110) = -1 ENOENT
(No such file or directory)
close(4)                                = 0
brk(0)                                  = 0x807d000
brk(0x807e000)                          = 0x807e000
open("/etc/hosts", O_RDONLY)            = 4
fcntl64(4, F_GETFD)                     = 0
fcntl64(4, F_SETFD, FD_CLOEXEC)         = 0
fstat64(4, {st_mode=S_IFREG|0644, st_size=153, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40017000
read(4, "# Do not remove the following li"..., 4096) = 153
close(4)                                = 0
munmap(0x40017000, 4096)                = 0
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0x40016000, 4096)                = 0
clone(child_stack=0, flags=0x1200011)   = 4527
--- SIGTERM (Terminated) ---
+++ killed by SIGTERM +++

Version-Release number of selected component (if applicable):
What works?
kernel-2.4.20-2.2    (from Phoebe)
kernel-2.4.18-19.8.0 (from Psyche)

What exhibits this behavior?
kernel-2.4.20-2.11
kernel-2.4.20-2.15
glibc-2.3.1-31
glibc-2.3.1-35
(Probably more versions but this is all I was able to download.)

How reproducible:
Always

Steps to Reproduce:
1. Start service canna with recent Rawhide kernels.
    
Actual Results:  
Reported failure, however Canna works.

Expected Results:
Should not say it failed.

Comment 1 Arjan van de Ven 2003-01-15 11:57:04 UTC
it looks like canna depends on whether child or parent run first after a fork().
It cannot depend on that since both can happen, it's just that newer kernels
make the other one happen more often

Comment 2 Bill Nottingham 2003-01-20 21:25:44 UTC
*** Bug 82163 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2003-02-04 20:21:10 UTC
*** Bug 83367 has been marked as a duplicate of this bug. ***

Comment 4 Nakai 2003-02-05 07:48:28 UTC
This canna lying bug was sometimes happened in the former RHL.

3.6-12 should have fixed this with simple check command, cannaping.

Comment 5 Nakai 2003-02-05 07:50:04 UTC
Confirmed it works on kernel-2.4.20-2.21

Comment 6 Warren Togami 2003-02-05 08:27:25 UTC
Confirmed with pure rawhide and kernel-2.4.20-2.33 too.



Note You need to log in before you can comment on or make changes to this bug.