Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81922 - booting may be failed if the usb storage is connected at installation time.
Summary: booting may be failed if the usb storage is connected at installation time.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-15 07:14 UTC by Shinya Narahara
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-15 17:06:43 UTC


Attachments (Terms of Use)

Description Shinya Narahara 2003-01-15 07:14:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [ja] (WinNT; U)

Description of problem:
The system which is installed by using kickstart
file on usb-floppy, may fail to boot
when the usb-floppy device is disconnected from the system.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install with kickstart, from usb-floppy
2.disconnect usb-floppy
3.reboot


Actual Results:  kernel panic: can't find root fs.

Expected Results:  boot normally.

Additional info:

This occures only on system which has root fs on scsi device.
The cause is an appreciation order of anaconda and mkinitrd.
We believe the removable device(like usb-floppy, usb-hdd)
must be appreciated at last time, but current anaconda do
at first.

The system which has fixed scsi disk and usb-floppy
connected, shows disks as:
    /dev/sda = usb-floppy
    /dev/sdb = fixed scsi disk

It should be:
    /dev/sda = fixed scsi disk
    /dev/sdb = usb-floppy
because removing usb-floppy from system, doesn't have
any effects.

To fix this, we must make 2 patches for anaconda and mkinitrd.
The anaconda one is below:

--- anaconda-7.2/loader/loader.c.org	Tue Jan  7 04:54:54 2003
+++ anaconda-7.2/loader/loader.c	Tue Jan  7 04:57:50 2003
@@ -2434,10 +2434,10 @@
 
     mlLoadModule("hid", NULL, modLoaded, modDeps, NULL, modInfo, flags);
     mlLoadModule("keybdev", NULL, modLoaded, modDeps, NULL, modInfo, flags);
-
+/*
     if (FL_NOUSBSTORAGE(flags)) return 0;
     mlLoadModule("usb-storage", NULL, modLoaded, modDeps, NULL, modInfo, flags);
-
+*/
     return 0;
 }
 
@@ -2719,6 +2719,9 @@
 	busProbe(modInfo, modLoaded, modDeps, probeOnly, &kd, flags);
 	if (probeOnly) exit(0);
     }
+    if (!FL_NOUSBSTORAGE(flags)) {
+        mlLoadModule("usb-storage", NULL, modLoaded, modDeps, NULL, modInfo, flags);
+    }
 
     if (FL_KSHD(flags)) {
 	ksFile = "/tmp/ks.cfg";

Comment 1 Michael Fulbright 2003-01-15 17:06:43 UTC
This was fixed in 7.3.


Note You need to log in before you can comment on or make changes to this bug.