Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81921 - Internal compiler error in delete_insn, at cfgrtl.c:139
Summary: Internal compiler error in delete_insn, at cfgrtl.c:139
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-15 07:09 UTC by Shelley Gong
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 19:37:40 UTC


Attachments (Terms of Use)

Description Shelley Gong 2003-01-15 07:09:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I try to build my own kernel from kernel source. I changed option -O2 in  CFLAGS
in /usr/src/linux-2.4/Makefile to -O -g. 
Then do make mrproper, make menuconfig, make bzImage, and then make modules.
During make modules, I got the following error message. 

gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-14/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O -g -fno-strict-aliasing -fno-common   -fomit-frame-pointer
-pipe -mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.18-14/include/linux/modversions.h  -nostdinc -I
/usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=tg3  -c -o
tg3.o tg3.c
tg3.c: In function `tg3_start_xmit_4gbug':
tg3.c:2344: Internal compiler error in delete_insn, at cfgrtl.c:139
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [tg3.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.18-14/drivers/net'
make[1]: *** [_modsubdir_net] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-14/drivers'
make: *** [_mod_drivers] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Change option -O2 in CFLAGS in /usr/src/linux-2.4/Makefile to -O -g

2. Make mrproper, make menuconfig, make bzIamge

3. Make modules
    

Actual Results:  I got the following error message. 

gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-14/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O -g -fno-strict-aliasing -fno-common   -fomit-frame-pointer
-pipe -mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.18-14/include/linux/modversions.h  -nostdinc -I
/usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=tg3  -c -o
tg3.o tg3.c
tg3.c: In function `tg3_start_xmit_4gbug':
tg3.c:2344: Internal compiler error in delete_insn, at cfgrtl.c:139
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [tg3.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.18-14/drivers/net'
make[1]: *** [_modsubdir_net] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-14/drivers'
make: *** [_mod_drivers] Error 2


Expected Results:  build sucessful

Additional info:

Comment 1 Jakub Jelinek 2003-02-17 15:04:26 UTC
Is it reproduceable?
If yes, please attach preprocessed tg3.i (add -save-temps to gcc options).

Comment 2 Jakub Jelinek 2004-10-03 19:37:40 UTC
No feedback, closing.  The kernel has built since then for many
people, so most likely this was a hardware issue.


Note You need to log in before you can comment on or make changes to this bug.