Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81920 - the media that kickstart file is writen should be mount readonly.
Summary: the media that kickstart file is writen should be mount readonly.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-15 06:49 UTC by Shinya Narahara
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-15 17:43:18 UTC


Attachments (Terms of Use)

Description Shinya Narahara 2003-01-15 06:49:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; T312461)

Description of problem:
When using HDD kickstart(ex. ks=hd:hda/ks.cfg),
it fails sometimes. Because anaconda mounts
HDD with read-write option.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.prepare kickstart file on floppy disk, in IDE-floopy drive etc. 
2.turned on the protect notch(readonly).
3.kickstart install with ks=hd:hda/ks.cfg
    

Actual Results:  /tmp/ks.cfg can't be found. Installation is stopped

Expected Results:  /tmp/ks.cfg can be found, and installation is continued.

Additional info:

Almost this is not a problem, but especially for
floppy device, it might be serious issue.
Now we have many abnormal floopy device,
IDE-floppy, USB-floppy etc. These are behaving
/dev/hd[a-z] or /dev/sd[a-z], like a normal
fixed disk. Anaconda can't treat them as a
floopy, so we must specify it is fixed disk
when kickstart installation.

The mount option of anaconda for fixed disk
doesn't have "-r", then mount command of
bussy box brings mount error when the floopy
disk can't be writen.

Just add "-r" option into anaconda's "mount".

Comment 1 Jeremy Katz 2003-01-15 17:43:18 UTC
This is fixed in our current trees


Note You need to log in before you can comment on or make changes to this bug.