Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81916 - mouse "stutters" or "staggers" in Tux Racer
Summary: mouse "stutters" or "staggers" in Tux Racer
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tuxracer
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-15 05:08 UTC by Elton Woo
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-05 18:10:47 UTC


Attachments (Terms of Use)

Description Elton Woo 2003-01-15 05:08:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
When I start Tux Racer it comes up full screen. However, it is next to impossible
to select the menu choices and start the game as my mouse becomes uncontrollable.
The pointer "stutters" sround the screen and cannot be properly controlled to
select a
menu item and start the game. 

The problem has also existed in Psyche (RH 8.0).

CPU: AMD Athlon 1.G, Award Bios Rev. 1007
Motherboard: Asus A7VE/550, VIA KT133 chipset
Video Subsystem --
Viewsonic 17 monitor
Jaton 3DForce B-32 Plus AGP card
Screen Resolution: 1024 x 768 x 24-bit colour.





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start Tux Racer from the menu
2. Main game menu comes up full-screen.
3. Try to select a menu item, e.g. start game, quit, etc.
    

Actual Results:  Mouse pointer becomes uncontrollable, and jumps around the
screen. Game has to be either killed or exited, as it is "unplayable".

Expected Results:  Mouse pointer should function as in any other mouse-supported
application, and move smoothly from one menu item to another.

Additional info:

I'm aware that this is an nVidia problem, but it would "be REALLY
nice if" this were fixed for the next version of RH.

Comment 1 Ingo Molnar 2003-02-18 11:47:54 UTC
I can occasionally see this effect with a radeon 8500 as well.

the only thing that helps in this case is to turn off some rendering features of
the game. Strangely, turning them back on in the game does not produce the
extreme-slowdown.

Comment 2 Michal Ambroz 2003-03-03 05:59:03 UTC
This problem is most probably about hardware acceleration of your card.
Tuxracer does the same here with original Xfree drivers - it is so slow, that
when I move mouse that movement has quite some delay and no animation (it just
appears in new position).

But when I use accelerated drivers from nvidia it is OK. 
Please Elton can you try nvidia drivers if the problem stills?
Here is src.rpm package for Phoebe-3:
http://rebus.webz.cz/#nvidia


Comment 3 Elton Woo 2003-09-04 16:51:22 UTC
The NVIDIA drivers, once installed *do* correct this problem, so I would suggest
this bug be closed. (?) 
Latest version (03 Sep. 2003:NVIDIA-Linux-x86-1.0-4496-pkg2.run).

Comment 4 Ngo Than 2003-09-05 18:10:47 UTC
yes, you have to setup correctly your X to have DRI support. It's not a bug in
tuxracer.


Note You need to log in before you can comment on or make changes to this bug.