Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81903 - Missing fc and jobid builtin commands
Summary: Missing fc and jobid builtin commands
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ash
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Ben Levenson
URL:
Whiteboard:
: 84450 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-15 01:12 UTC by Derek Tattersall
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-16 13:45:58 UTC


Attachments (Terms of Use)
Manual page patch, eliminating the noted commands. (deleted)
2003-02-18 21:43 UTC, Lon Hohberger
no flags Details | Diff

Description Derek Tattersall 2003-01-15 01:12:32 UTC
Description of problem: The builtin commands fc and jobid return not found when
executed.


Version-Release number of selected component (if applicable):
/ash-0.3.8

How reproducible:
Happens when ash used interactively

Steps to Reproduce:
1.execute ash -i to get an interactive shell
2.execute one or more commands
3.execute fc -l
    
Actual results:
fc: not found or jobid: not found

Expected results:
history listing or the id of the current job

Additional info:
man page says the commands exist, but they don't appear in builtins.c in the source.

Comment 1 Lon Hohberger 2003-02-18 17:18:02 UTC
*** Bug 84450 has been marked as a duplicate of this bug. ***

Comment 2 Lon Hohberger 2003-02-18 21:43:22 UTC
Created attachment 90166 [details]
Manual page patch, eliminating the noted commands.

Comment 3 Lon Hohberger 2003-02-18 21:44:58 UTC
The patch above fixes the man page, and will go into rawhide as soon as the next
release is complete.

In the meantime, packages including the fix are available from:

http://people.redhat.com/lhh/



Comment 4 Lon Hohberger 2003-02-20 17:01:17 UTC
Forgot to say "why" the commands aren't available in the first place.  

Part of the reason has to do with the root of where ash came from, namely
NetBSD.  NetBSD has a library called 'libedit' which the history functions used
in order to edit/change pre-entered commands.  This library isn't currently
available on Red Hat Linux.

Also, ash is only really provided as a 'small' shell - a replacement when 'bash'
isn't needed.   ash.static is a very good shell for things like rescue disks, as
it can execute fairly complex shell code with minimal space taken up on the
disk: as shipped with RHL 8.0, ash.static is 500kb or so; bash (dynamic!) is
around 620kb.

Comment 5 Lon Hohberger 2003-04-16 13:45:58 UTC
ash-0.3.8-11 should be in rawhide soon.  Until such time, you man obtain it from:

http://people.redhat.com/lhh/ash-0.3.8-11.i386.rpm
http://people.redhat.com/lhh/ash-0.3.8-11.src.rpm



Note You need to log in before you can comment on or make changes to this bug.