Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81870 - duplicate or missing items in redhat menus KDE / Gnome
Summary: duplicate or missing items in redhat menus KDE / Gnome
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase
Version: phoebe
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-14 19:56 UTC by Elton Woo
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-04 22:32:37 UTC


Attachments (Terms of Use)

Description Elton Woo 2003-01-14 19:56:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Both KDE and Gnome have duplicate entries and invoke the *same* application,
from the duplicate entry.

In Gnome _and KDE there are *two* entries for Balsa.
In KDE only, there are *two* entries for Word Translator.

After installing gkrellm from rawhide, there are NO menu entries for
either KDE or Gnome, so this app has to be launched from a console prompt.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Update redhat-menus; install gkrellm
2. Login to KDE or
3. Gnome desktop
    

Actual Results:  Duplicate entries found in menus, as described above. 
No menu entry for installed application (gkrellm) _even after_
a system reboot / shutdown & restart.

Expected Results:  *single* entries for Word Translator and Balsa, with a new
menu icon for Gkrellm

Additional info:

Versions of  some packages currently installed (from rawhide):

redhat-menus-0.33-1
gkrellm-2.1.5-1
wordtrans-kde-1.1pre12-2
wordtrans-1.1pre12-2
wordtrans-web-1.1pre12-2
wordtrans-qt-1.1pre12-2
balsa-2.0.5-1
htmlview-2.0.0-9
xmms-1.2.7-16.p
kdelibs-3.1-0.5
gnome-pilot-0.1.71-1
kdebase-3.1-0.9
control-center-2.1.3-1
openoffice-1.0.1-8
gnome-desktop-2.1.90-1
gnome-vfs2-2.1.6-2
nautilus-2.1.6-1
desktop-printing-0.1.10-5
gnome-panel-2.1.90.1-3

Comment 1 Havoc Pennington 2003-01-14 20:14:35 UTC
Split off balsa and gkrellm issues:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81872
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81876

Reassinging duplicate-kde issue.

Comment 2 Elton Woo 2003-01-17 03:19:27 UTC
 I've updated licq from rawhide (licq-1.2.0a-6.i386.rpm), and now LICQ
*doesn't* show up in the Gnome menus (I haven't looked in KDE yet)

Comment 3 Elton Woo 2003-01-17 03:23:02 UTC
See also Bug 81202

Comment 4 Elton Woo 2003-01-17 05:59:24 UTC
LICQ is also now absent from the KDE menus (after installation of
licq-1.2.0a-6.i386.rpm).

Comment 5 Elton Woo 2003-01-17 19:03:54 UTC
Invoking LICQ from a console prompt, rather than from the startup programs
(since it's NOT
in the menus)  ... give me this output:

[ace@dhcp-87-919 ace]$ licq
sh: line 1: soundwrapper: command not found
sh: line 1: soundwrapper: command not found
sh: line 1: soundwrapper: command not found
sh: line 1: soundwrapper: command not found
sh: line 1: soundwrapper: command not found
sh: line 1: soundwrapper: command not found
 


Comment 6 Ngo Than 2003-01-21 14:44:03 UTC
there are 2 Word Translator with different GUI, one with Qt and another one with
KDE.
It's not a bug. I recommend you should remove the one with GUI Qt

Comment 7 Elton Woo 2003-01-24 19:01:28 UTC
The bug has resurfaced in Phoebe2 (two entries for Word Translator under KDE,
missing menu entries for LICQ in *both* KDE and Gnome.

NOTE: somewhat related problem: there are two *differently titled* entries in the
menus which point to the _same_ application: "IRC Client" and "XChat" (both invoke 
Xchat, of course).

Comment 8 Ngo Than 2003-02-04 22:32:37 UTC
1) wordtrans-qt/wordtrans-kde:
you have installed the both, which have same menu description. It's fixed now in
1.1pr12-4

2) LICQ menu entry works for me, with licq-1.2.3-5

3) IRC Client" and "XChat"
it seems to be fixed in xchat-1.8.11-6. It works for me with this release.


Note You need to log in before you can comment on or make changes to this bug.