Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 818611 - X11 forwarding does not work for xguest_u
Summary: X11 forwarding does not work for xguest_u
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.3
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Miroslav Vadkerti
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-03 14:09 UTC by Miroslav Vadkerti
Modified: 2012-06-20 12:34 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.7.19-149.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 12:34:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0780 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2012-06-19 20:34:59 UTC

Description Miroslav Vadkerti 2012-05-03 14:09:08 UTC
Description of problem:
When trying to use X forward to xguest_u user -> this is not possible

Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-147.el6

How reproducible:
100%

Steps to Reproduce:
# be sure to have xorg-x11-xauth package installed
useradd -Z staff_u staff
useradd -Z xguest_u xguest
# now set passwords for staff and xguest users
ssh staff@localhost
export DISPLAY=0:0
ssh xguest@localhost
echo $DISPLAY
  
Actual results:
DISPLAY variable empty -> X11 forwarding not working

Expected results:
DISPLAY variable not empty and with correct content (i.e. localhost:10.0) -> X11 forwarding working

Additional info:

Comment 1 Daniel Walsh 2012-05-03 14:30:04 UTC
I don't think this is something we want to allow for the default xguest_u user.  He should not be sending his X Display to other machines.

Comment 4 Miroslav Grepl 2012-05-03 20:45:06 UTC
(In reply to comment #1)
> I don't think this is something we want to allow for the default xguest_u user.
>  He should not be sending his X Display to other machines.

Actually I was thinking about a boolean but yes, it does not make sense to allow it for xguest_u.

Comment 26 errata-xmlrpc 2012-06-20 12:34:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0780.html


Note You need to log in before you can comment on or make changes to this bug.