Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 818161 - memory leaks since 3.2.6
Summary: memory leaks since 3.2.6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 3.2.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Amar Tumballi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-02 11:06 UTC by Calin Don
Modified: 2013-12-19 00:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-18 09:31:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Calin Don 2012-05-02 11:06:05 UTC
Hi,

I have a setup with 7 gluster nodes, 5 of them are running 3.2.5 and 2 are running 3.2.6.

The storage is on two nodes of the 5 running 3.2.5.

On the ones with 3.2.6 the memory usage of glusterfs is constantly growing, and reached 10GB in about two weeks while on the nodes with 3.2.5 it is steady between 300 and 500 MB.

Let me know how to proceed further.

Thanks,
Calin

Comment 1 Amar Tumballi 2012-05-02 16:39:28 UTC
Hi Calin,

Thanks for the info, and can you please let us know the general pattern of operations made on mount point? also the type of the volume (ie, gluster volume info).

Comment 2 Calin Don 2012-05-09 14:13:18 UTC
Hi Amar,

This is the mount point in question:

localhost:/instances on /instances type nfs (rw,noatime,mountproto=tcp,intr,ac,acregmax=120,acdirmax=120,acregmin=10,acdirmin=60,nolock,addr=127.0.0.1,mountaddr=127.0.0.1)

I use NFS over Gluster and mount it from localhost as described here: http://community.gluster.org/a/nfs-performance-with-fuse-client-redundancy/

It is used for serving web applications (some php files + static files).

Here is the output of # gluster volume info

Volume Name: instances
Type: Replicate
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: data1-z1.presslabs.net:/bricks/instances
Brick2: data2-z1.presslabs.net:/bricks/instances

Comment 3 Amar Tumballi 2012-05-10 07:43:45 UTC
Calin, Can you try our latest qa release http://bits.gluster.com/pub/gluster/glusterfs/src/glusterfs-3.3.0qa40.tar.gz if you are not yet on production? This would help us to see if this is already a fixed issue in upcoming 3.3.0 release.

Comment 4 Calin Don 2012-05-10 09:27:51 UTC
(In reply to comment #3)
> Calin, Can you try our latest qa release
> http://bits.gluster.com/pub/gluster/glusterfs/src/glusterfs-3.3.0qa40.tar.gz if
> you are not yet on production? This would help us to see if this is already a
> fixed issue in upcoming 3.3.0 release.

Unfortunately all the nodes are in production. Is anything I can do to track down these issues?

Comment 5 Amar Tumballi 2012-06-07 10:54:03 UTC
Calin Don,

We made the release of GlusterFS-3.3.0, Please upgrade to that version which should fix your issue.

Regards,
Amar

Comment 6 Calin Don 2012-06-18 09:31:35 UTC
Although I didn't upgrade to 3.3 yet, found that there were no issues with 3.2.6. The memory increase was caused by some problems with hostnames resolutions; the peers running 3.2.6 could not be resolved by the other peers in the network.


Note You need to log in before you can comment on or make changes to this bug.