Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 818124 - EditXml of an application Blueprint with deleted image shows : "Missing template deployables/show..."
Summary: EditXml of an application Blueprint with deleted image shows : "Missing templ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
Assignee: Angus Thomas
QA Contact: Rehana
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-02 09:50 UTC by Shveta
Modified: 2012-12-04 15:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Trying to Edit the Application Blueprint XMl for a Blueprint with deleted images resulted in an error display message showing: "Missing template deployables/show with {:handlers=>[:builder, :rjs, :haml, :rhtml, :erb, :rxml], :locale=>[:en, :en], :formats=>[:json, :js, "*/*"]} in view paths "/usr/share/aeolus-conductor/app/views". This fix allows images to be deleted without affecting Application Blueprints and the error no longer appears when editing the Application Blueprint XML.
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:24 UTC


Attachments (Terms of Use)
err (deleted)
2012-05-02 09:50 UTC, Shveta
no flags Details
ss (deleted)
2012-05-02 12:39 UTC, wes hayutin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 19:51:45 UTC

Description Shveta 2012-05-02 09:50:04 UTC
Created attachment 581555 [details]
err

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. This is with reference to https://bugzilla.redhat.com/show_bug.cgi?id=818122
2. Built an image , created application blueprint 
3. Deleted image , Catalog -- Application BP and edit xml shows this header message : 
"Missing template deployables/show with {:handlers=>[:builder, :rjs, :haml, :rhtml, :erb, :rxml], :locale=>[:en, :en], :formats=>[:json, :js, "*/*"]} in view paths "/usr/share/aeolus-conductor/app/views" "
  
Actual results:


Expected results:


Additional info:


rpm -qa|grep aeolus
aeolus-conductor-0.8.13-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-all-0.8.13-1.el6_2.noarch
aeolus-conductor-doc-0.8.13-1.el6_2.noarch
aeolus-conductor-daemons-0.8.13-1.el6_2.noarch

Comment 1 wes hayutin 2012-05-02 12:39:50 UTC
Created attachment 581610 [details]
ss

hrm.. that is odd.. 
If the image id is not valid, the view xml button for an application blueprint should turn black, and be marked invalid.

When I walk through the recreate:
1. create image
2. create app blueprint
3. delete image
4. revisit app blueprint

I get the message in the screenshot.

Is there something else in the recreate that I am not hitting?
Are you using multiple browswers?

Comment 2 Shveta 2012-05-04 07:20:38 UTC
Steps to recreate : 

1) Create Image 
2) Create App BP
3) delete Image 
4) revisit app BP .. leave the page for 2 mins .. after two mins or so click 
on Edit Xml .

You will see the error 

This is reproduced with single browser FF

Comment 5 Dave Johnson 2012-08-07 17:24:12 UTC
This appears to be fixed, moving to Modified

Comment 7 Dave Johnson 2012-09-19 18:04:29 UTC
good 2 go with:

aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch

Comment 9 errata-xmlrpc 2012-12-04 15:07:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html


Note You need to log in before you can comment on or make changes to this bug.