Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81798 - Can no longer only enter middle portion of hostname to access web sites
Summary: Can no longer only enter middle portion of hostname to access web sites
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL: redhat
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-14 03:11 UTC by long
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-11 22:11:40 UTC


Attachments (Terms of Use)

Description long 2003-01-14 03:11:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Before mozilla 1.0.1 I could enter 'google' or 'redhat' or 'slashdot' in the URL
entry box and it would automatically try google.com, www.google.com,
www.redhat.com, etc.  Of course I had to have Enable Internet Keywords turned
off in my preferences to make this work.  Now, however, if I just enter the word
redhat in the URL bar I get this message:

The connection was refused when attempting to contact redhat.

I *really* prefer the old behavior as it made for speedy manual browsing (now I
have to type www.redhat.com if I want to go to Redhat's home page).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start mozilla 1.0.1
2. Edit menu -> Preferences -> Navigator -> Smart Browsing
3. Uncheck Enable Internet Keywords, click OK
4. Delete anything in the URL bar and enter the word 'redhat'.  Press Enter.

    

Actual Results:  "The connection was refused when attempting to contact redhat"
comes up in a new dialog box.


Expected Results:  I should be taken to www.redhat.com.


Additional info:

mozilla-1.0.1-2.7.3 is the rpm -q output

Comment 1 long 2003-04-11 22:11:40 UTC
Problem solved.  It turns out I had a domain in the 'search' line in
/etc/resolv.conf that was set up to do wildcard DNS so everytime I would enter
'redhat' or 'google' it would try and connect to redhat.wildcard.org or
google.wildcard.org and end up failing to connect.


Note You need to log in before you can comment on or make changes to this bug.