Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81787 - up2date error with Traceback
Summary: up2date error with Traceback
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-14 00:09 UTC by David Mitchell
Modified: 2007-04-18 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-10 16:07:57 UTC


Attachments (Terms of Use)

Description David Mitchell 2003-01-14 00:09:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)

Description of problem:
I tried to run up2date for the first time, and I got the following stdout:

[dmitch@jules dmitch]$ up2date
Traceback (innermost last):
  File "/usr/sbin/up2date", line 17, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 8, in ?
    import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 11, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 15, in ?
    import rpmUtils
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 274, in ?
    rpm_version = getRpmVersion()
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 269, in getRpmVersion
    raise up2dateErrors.RpmError("Couldn't determine what version of rpm you are
running.\nIf you get this error, try running \n\n\t\trpm --rebuilddb\n\n")
up2date_client.up2dateErrors.RpmError: RPM error.  The message was:
Couldn't determine what version of rpm you are running.
If you get this error, try running 

		rpm --rebuilddb


[dmitch@jules dmitch]$ 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Installed Redhat 6.2 Professional
2.Ran up2date from the command line as root
    

Additional info:

Comment 1 Adrian Likins 2003-01-15 05:00:07 UTC
What happens when you run `rpm --rebuilddb`
and try it again?

Comment 2 David Mitchell 2003-01-15 20:15:22 UTC
Same results...

Comment 3 Adrian Likins 2003-01-16 06:09:24 UTC
what's happening is up2date is unable to find a package that
provdes "redhat-release"

can you try:
     rpm -q --what-provides "redhat-release"

also:

    rpm -q redhat-release

Comment 4 David Mitchell 2003-01-17 18:10:56 UTC
Thanks for the response. :) Here's the results:

[root@jules dmitch]# rpm -q --whatprovides "redhat-release"
redhat-release-6.2-1
[root@jules dmitch]# rpm -q redhat-release
redhat-release-6.2-1
[root@jules dmitch]# 


Comment 5 Need Real Name 2003-03-10 16:00:24 UTC
Adding the package corrected this problem in my case. 
Up2date works for me now

Comment 6 Josef Komenda 2003-03-10 16:07:57 UTC
Fixed, closing.


Note You need to log in before you can comment on or make changes to this bug.