Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81786 - win4lin running too fast
Summary: win4lin running too fast
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.1
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 23:23 UTC by carl
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-12-17 00:27:02 UTC


Attachments (Terms of Use)

Description carl 2003-01-13 23:23:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

Description of problem:
When I upgraded my kernel to 2.4.18-19.7.x Windows 98 in win4lin version 3.0.10
started running too fast.  It's about 5 times faster than it should be (the
clock in Windows 98 shows that it is running about 5 times faster).  I asked
Netraverse about this problem and they responded with the following message:

-----------------
Thank you for your inquiry. Unfortunately, we cannot offer support for the
latest Red Hat 7.x kernels and Win4Lin 3.0 because of changes Red Hat made to
their latest kernel versions. The reason the clock runs fast in Windows is
because the new Red Hat kernels are using an increased clocktick frequency. This
change (and others) in the new Red Hat kernels have necessitated enhancements be
made to Win4Lin to support it. These enhancements were made to Win4Lin 4.0, but
will not be backported to Win4Lin 3.0. If you wish to continue the new Red Hat
kernel, you will need to upgrade to Win4Lin 4.0. Otherwise, Win4Lin 3.0 does run
on the original Red Hat 7.x kernels (pre-2.4.18-18.7.x) as well as the latest
versions of Mandrake and SuSE.

Regards,
Amanda Owens
NeTraverse Support
http://www.netraverse.com
----------------------------

Is this true?  And if so, what are my options (if any) to fix the problem
besides spending another $90 on win4lin?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run Windows 98 under win4lin
2.Watch clock in lower right hand corner increment the minutes every 10 to 12
seconds.

    

Actual Results:  The clock in Windows 98 ran 5 times too fast

Expected Results:  The clock in Windows 98 should run at the same rate as normal
time.

Additional info:

Comment 1 Arjan van de Ven 2003-01-13 23:31:45 UTC
nettraverse bad bug, they didn't code according to kernel practices/rules (not
just Red Hat's but kernel.org's as well).
however you can work around this by installing the i586 kernel which has HZ=100



Note You need to log in before you can comment on or make changes to this bug.