Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 817643 - JBDS ESB editor - needs to support the new 1.4.0 ESB schema version
Summary: JBDS ESB editor - needs to support the new 1.4.0 ESB schema version
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Tooling
Version: 5.3.0 GA
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ER3
: 5.3.0 GA
Assignee: Brian Fitzpatrick
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-30 18:03 UTC by Len DiMaggio
Modified: 2012-06-19 14:16 UTC (History)
1 user (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-25 14:03:29 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker JBDS-2104 None Closed JBDS ESB editor - needs to support the new 1.4.0 ESB schema version 2012-05-30 13:10:37 UTC

Description Len DiMaggio 2012-04-30 18:03:21 UTC
Description of problem:

JBDS ESB editor - needs to support the new 1.4.0 ESB schema version

see: https://issues.jboss.org/browse/JBDS-2104

Version-Release number of selected component (if applicable):
SOA-P 5.3.ER2

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 JBoss JIRA Server 2012-05-03 17:33:13 UTC
Viacheslav Kabanovich <scabanovich@exadel.com> made a comment on jira JBDS-2104

Could you please attach jbossesb-1.4.0.xsd, I cannot find it in jbossesb SVN under /trunk/product/etc/schemas/xml where all other versions of the ESB schema are located.

Comment 2 JBoss JIRA Server 2012-05-03 20:49:42 UTC
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira JBDS-2104

I've asked Tom Cunningham to attach the schema to the JIRA.

Comment 3 JBoss JIRA Server 2012-05-04 12:16:48 UTC
Tom Cunningham <tcunning@redhat.com> made a comment on jira JBDS-2104

The new schema is actually the 1.3.1 version found here : 

http://anonsvn.jboss.org/repos/labs/labs/jbossesb/branches/JBESB_4_11_CP/product/etc/schemas/xml/

Comment 4 JBoss JIRA Server 2012-05-04 16:56:23 UTC
Viacheslav Kabanovich <scabanovich@exadel.com> made a comment on jira JBDS-2104

Version 1.3.1 is covered by JBIDE-11769. Then we have to wait for 1.4.0 schema to be committed explicitly to the repository, and to determine in which version of JBoss Tools the support should be implemented.

Comment 5 JBoss JIRA Server 2012-05-25 13:04:22 UTC
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBDS-2104

There seem to be some confusion here.

The only schema we can find in both community and product branches is 1.3.1.

That is covered by JBIDE-11769.

Can we reject this one as invalid since there are no 1.4.0 schema version !?

Comment 6 JBoss JIRA Server 2012-05-25 14:08:26 UTC
Len DiMaggio <ldimaggi@redhat.com> updated the status of jira JBDS-2104 to Closed

Comment 7 JBoss JIRA Server 2012-05-25 14:08:26 UTC
Len DiMaggio <ldimaggi@redhat.com> made a comment on jira JBDS-2104

See the linked bz - the changes are in the 1.3.1 schema instead.


Note You need to log in before you can comment on or make changes to this bug.