Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81763 - registration by activation key subscribes to unspecified powertools channels.
Summary: registration by activation key subscribes to unspecified powertools channels.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 20:33 UTC by Mike McLean
Modified: 2007-10-24 02:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-13 20:44:31 UTC


Attachments (Terms of Use)

Description Mike McLean 2003-01-13 20:33:56 UTC
* 7.0, 7.1
* rhnreg_ks

my 7.[01] boxes are getting subscribed to the powertools subchannel (when
registered via activation key) even though the activation key has that channel
unselected.

Comment 1 Mihai Ibanescu 2003-01-13 20:42:49 UTC
Yes, because:

- your registration token does not specify a base channel, because the editor
did not allow you to select one
- if no channel is present in the registration key, it computes the channels to
subscribe based on the rhnDistChannelMap rules
- all 7.[01] boxes are automatically subscribed to the powertools channels,
based on the above-mentioned rules.


Comment 2 Mihai Ibanescu 2003-01-13 20:44:31 UTC
Closing. To quote gdk:

So the answer is "works as designed," although it's debatable whether it was
designed very well.  :-)

Really, not much I can do.


Note You need to log in before you can comment on or make changes to this bug.