Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81739 - error "cannot execute binary file" when attempting to run program "kcml"
Summary: error "cannot execute binary file" when attempting to run program "kcml"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 17:09 UTC by Jim Clement
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-05 14:13:59 UTC


Attachments (Terms of Use)

Description Jim Clement 2003-01-13 17:09:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
I installed redhat 8.0. I moved software package named "kcml" from SCO unix to 
redhat system using cpio. When I tried to execute the program, I received an 
error "cannot execute binary file". When I did "file kcml", I get "80386 COFF 
executeable". I checked all file permissions and ownership to be correct. I am 
an SCO Unix professional, with 12+ years running this software on SCO. I also 
loaded this same software on SuSE Linux and the programs executed without 
problems. I submitted the error to Redhat Web Support, and was asked by them to 
submit this to Bugzilla.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run program by entering "/usr/lib/KCML/kcml DEVICES" (file "DEVICES" is a 
parameter file giving "kcml" the locations and file names of required files)
2.
3.
    

Actual Results:  -bash: /usr/lib/KCML/kcml: cannot execute binary file

Expected Results:  program should execute

Additional info:

This software has been running fine for the past 12 years on SCO Unix. I 
contacted the company that distributed the software and they explained it 
should be Linux compatable. I first loaded it on SuSe Linux and it executed 
fine. I thought I would rather migrate the software from SCO to Redhat Linux 
due a better availability of support and training. I need to migrate from SCO 
because of some needed hardware drivers that are available for Redhat & SuSE 
Linux, that are not being offered f

Comment 1 Arjan van de Ven 2003-01-13 17:28:18 UTC
did you load the modules needed for linux-abi ?
(linux-abi is the sco interoperability stuff)

Comment 2 Michael K. Johnson 2003-01-13 19:06:56 UTC
I'm not sure what the vendor meant by "Linux compatible" but SCO
binaries are not "Linux compatible" unless you consider the linux-abi
project, maintained separately from Linux, to provide that capability.
We have sometimes but not always included linux-abi or its predecessor
"ibcs2" in Red Hat Linux but have not considered it supported functionality
when we have included it; it has been included on an as-is basis when it
has been included at all.

Kerridge's web site says (at http://www.kcml.com/toolset/FAQs/nsdefault.html)
that Linux is supported natively as of KCML 6.00 -- we would recommend that
you obtain a native copy of KCML for Linux; while we can't give any
guarantees, we would expect a native application to work better than a
non-native application.


Note You need to log in before you can comment on or make changes to this bug.