Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81737 - etc/hosts entries prevent nfs (and telnet) from working
Summary: etc/hosts entries prevent nfs (and telnet) from working
Keywords:
Status: CLOSED DUPLICATE of bug 76543
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 16:58 UTC by Robert Youngjohns
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:09 UTC


Attachments (Terms of Use)

Description Robert Youngjohns 2003-01-13 16:58:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79C-CCK-MCD  [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
Entered as an NFS component error, but I suspect is more widespread.

With local HOSTS entries, NFS mounts fail with RPC portmap error using  host
name or IP address. (Similarly, Telnet fails with connection refused.) Ping
works.

Remove the HOSTS entries and NFS/Telnet works fine with IP address.  All worked
fine with redhat 7.1

I've seen comments about a bug that sounds similar and which was preventing some
sites (including redhat) migrating to 8.0, but can't find reference to this on
bugzilla.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. remove entries in etc/hosts - works
2. add entries to etc/hosts - fails
3.
    

Actual Results:  nfs mount fails with RPC portmap error. 

Expected Results:  nfs should have mounted remote filesystem

Additional info:

Comment 1 Robert Youngjohns 2003-01-16 17:32:40 UTC
I think this is probably a duplicate of 76543.

Comment 2 Steve Dickson 2004-06-16 00:38:38 UTC

*** This bug has been marked as a duplicate of 76543 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.