Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81734 - ldconfig kills the system
Summary: ldconfig kills the system
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc
Version: 1.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
: 80948 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 16:16 UTC by Sammy
Modified: 2016-11-24 14:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-15 15:51:02 UTC


Attachments (Terms of Use)

Description Sammy 2003-01-13 16:16:16 UTC
All of the errors reported saying that during an rpm upgrade things start 
segfaulting seem to result from the post scripts in any package that calls 
ldconfig. This is happening since glibc-2.3.1-26 (after -21) in rawhide. 
 
Just issuing "ldconfig" results in ALL binaries crashing. Rebooting from 
Phoebe CD1 and reinstalling glibc with --noscripts results in a working 
system. 
 
Could this be happening to people who have a modified /etc/ld.so.conf file? 
Since this is  a configuration file it is not replaced during the upgrade. 
 
I am in sync with rawhide of Jan 13, 2003.

Comment 1 Jakub Jelinek 2003-01-14 14:28:04 UTC
I certainly cannot reproduce anything like this.
What exactly do you have in /etc/ld.so.conf?
How do the crashes look like?
Do all programs crash, or just some? Say if you run /bin/echo.

Comment 2 Sammy 2003-01-14 16:52:47 UTC
Yes. I just did it again and /bin/echo gives "Segmentation fault" as well. Clue may lie 
in upgrade process. I have a notebook with all the same software and there is no 
problem there. The difference was: 
 
While doing the first upgrade to TLS based glibc/kernel/rpm I did it from the command 
line and not from anaconda. The upgrade crashed half-way during the glibc-2.3.1 
upgrade (glibc-common was fine) and went into the ldconfig problem mentioned above. 
I than booted up from Phoebe1 CD and tried to install from "linux rescue" mode. This 
seems to have some incompatibility with the current rawhide rpm databases, so the only 
way I could do it is to go back to older rpm and do the upgrades that way. The notebook 
was upgraded straight from anaconda. 

Comment 3 Sammy 2003-01-15 15:51:02 UTC
I have fixed this problem by reinstalling from an appropriate boot CD. It seems to be a 
problem if one tries to install from RH8.0 to current glibc without using anaconda and/or 
proper rpm/kernel. I am closing this as solved in rawhide. 

Comment 4 Sammy 2003-01-15 15:53:07 UTC
*** Bug 80948 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.