Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81730 - [RFE] Upgrade VNC to 3.3.6 from realvnc.com (new home of VNC)
Summary: [RFE] Upgrade VNC to 3.3.6 from realvnc.com (new home of VNC)
Keywords:
Status: CLOSED DUPLICATE of bug 72965
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vnc
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL: http://www.realvnc.com/download.html
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 15:30 UTC by James Manning
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:09 UTC


Attachments (Terms of Use)
sshot showing bad VNC server behavior for text-based terminal winow (deleted)
2003-01-13 15:47 UTC, James Manning
no flags Details

Description James Manning 2003-01-13 15:30:17 UTC
Description of problem:
Various bugs in VNC 3.3.3r2, mainly improperly handling window updates.  Best
handled by upgrading packages to 3.3.6 from available URL

http://www.realvnc.com/dist/vnc-3.3.6-2.src.rpm

related files:
http://www.realvnc.com/dist/vnc-3.3.6-x86_linux.tar.gz
http://www.realvnc.com/dist/vnc-3.3.6-2.i386.rpm
http://www.realvnc.com/dist/vnc-3.3.6-unixsrc.tar.gz
http://www.realvnc.com/dist/vnc-3.3.6-documentation.tar.gz

Version-Release number of selected component (if applicable):
3.3.3r2-43

How reproducible:
100%

Steps to Reproduce:
1. Mainly - run any terminal app (gnome-terminal, konsole, xterm)
2. hit it from a remote vnc viewer
3. notice updates of the window suck and are incomplete :)
    
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2003-01-13 15:32:43 UTC
Much too late for this cycle.

Comment 2 James Manning 2003-01-13 15:45:39 UTC
Here's the VNC server from RHL 8.0 (same VNC as Phoebe) demonstrating the bad
behavior for terminal windows.

http://www.sublogic.com/james/files/faruked_screen.gif

I'll go ahead and make it an attachment, too.

Note that graphical things that don't have text-based areas (like Kate, the KDE
editor) work fantastically (BitBlt usage broken, maybe?)

Expected it would be deferred, just wanted to get it logged before I forgot for
yet another cycle :)

Comment 3 James Manning 2003-01-13 15:47:12 UTC
Created attachment 89336 [details]
sshot showing bad VNC server behavior for text-based terminal winow

Comment 4 Tim Waugh 2003-01-13 15:52:08 UTC
Oh, that's already logged I think.

Note that 'vnc-3.3.3r2-43' is actually TightVNC right now.

Comment 5 Tim Waugh 2003-01-13 16:06:49 UTC

*** This bug has been marked as a duplicate of 72965 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:51:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.