Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81725 - rpm -q dev --> error
Summary: rpm -q dev --> error
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 13:24 UTC by Olivier Baudron
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 20:51:54 UTC


Attachments (Terms of Use)

Description Olivier Baudron 2003-01-13 13:24:39 UTC
$ rpm -q rpm
rpm-4.2-0.54

$ rpm -q dev
dev-3.3.2-1
error: db4 error(13) from db->close: Permission denied

Comment 1 Jeff Johnson 2003-01-13 15:43:44 UTC
I can't reproduce this. However, db-4.1.24 returns
errors from db-close. Harmless afaik, fix is gonna
be to not print the error message when the time comes.

Comment 2 Jeff Johnson 2003-01-13 15:43:56 UTC
I can't reproduce this. However, db-4.1.24 returns
errors from db->close. Harmless afaik, fix is gonna
be to not print the error message when the time comes.

Comment 3 Olivier Baudron 2003-01-13 16:32:39 UTC
The problem is not present with dev-3.3.1-3.
And you must 'rpm -q' as a normal user to see it.

Comment 4 Jeff Johnson 2003-01-14 20:51:54 UTC
Still WORKSFORME:

bash$ id                  
uid=2161(jbj) gid=2161(jbj) groups=2161(jbj)
bash$ rpm -q rpm dev
rpm-4.2-0.57
dev-3.3.2-1


Comment 5 Olivier Baudron 2003-01-16 12:22:47 UTC
This may be a db problem. I have db4-4.0.14-15 (rawhide and phoebe version) and
I could not find any db-4.1.24 package...

Comment 6 Jeff Johnson 2003-01-16 14:36:11 UTC
db-4.1.24 is internal to rpm sources.


Note You need to log in before you can comment on or make changes to this bug.