Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81721 - AC_CHECK_SIZEOF fails with GCC 3.0.4 (Red Hat 7.2)
Summary: AC_CHECK_SIZEOF fails with GCC 3.0.4 (Red Hat 7.2)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autoconf
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brian Brock
URL:
Whiteboard:
: 81719 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 11:51 UTC by Pascal Haakmat
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-13 12:37:31 UTC


Attachments (Terms of Use)
config.log for AC_CHECK_SIZEOF(int,4) run (deleted)
2003-01-13 11:53 UTC, Pascal Haakmat
no flags Details

Description Pascal Haakmat 2003-01-13 11:51:07 UTC
Description of problem:
autoconf 2.53 (as distributed with Red Hat 8) may have a bug.

Running autoconf on the following two-line configure.in:

AC_INIT(test, 0)
AC_CHECK_SIZEOF(int, 4)

generates a configure script that fails on gcc 3.0.4 (as distributed
with Red Hat 7.2). config.log has been attached.

Version-Release number of selected component (if applicable):
2.53

How reproducible:
Always

Steps to Reproduce:
1. Create two-line configure.in as described above on a Red Hat 8 system.
2. Run 'autoconf'.
3. Move generated 'configure' script to a Red Hat 7.2 system.
4. Run './configure'.
    
Actual results:
checking size of int... configure: error: cannot compute sizeof (int), 77

Expected results:
checking size of int... 4

Additional info:
--- Example:
$ gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.0.4/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --host=i386-redhat-linux --with-system-zlib
Thread model: posix
gcc version 3.0.4 (Red Hat Linux 7.2 3.0.4-1)
$ ./configure
<output deleted>
checking size of int... configure: error: cannot compute sizeof (int), 77
$ export CC=kgcc
$ kgcc -v
[p@awacs autoconf-bug]$ kgcc -v
Reading specs from
/usr/lib/gcc-lib/i386-glibc21-linux/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
<output deleted>
checking size of int... 4
$

Comment 1 Pascal Haakmat 2003-01-13 11:54:01 UTC
Created attachment 89333 [details]
config.log for AC_CHECK_SIZEOF(int,4) run

This is the config.log generated for AC_CHECK_SIZEOF(int,4). It makes no
difference whether the optional size parameter is used or not.

Comment 2 Pascal Haakmat 2003-01-13 11:55:10 UTC
*** Bug 81719 has been marked as a duplicate of this bug. ***

Comment 3 Pascal Haakmat 2003-01-13 12:09:46 UTC
Relevant part from the config.log:

> configure:2394: checking size of int
> configure:2672: gcc -o conftest -g -O2   conftest.c  >&5
> /tmp/cc3ItQrW.s: Assembler messages:
> /tmp/cc3ItQrW.s:416: Warning: Unrecognized .section attribute: want a,w,x
> /tmp/cc3ItQrW.s:416: Warning: Unrecognized .section attribute: want a,w,x
> /tmp/cc3ItQrW.s:416: Error: Rest of line ignored. First ignored character is
+`,'.
> configure:2675: $? = 1

When the '-O2' flag is removed from the compiler commandline then the test
succeeds as expected.

And sorry about the spam!


Comment 4 Pascal Haakmat 2003-01-13 12:33:56 UTC
Well, it seems my GCC 3.0.4 installation has simply become hosed overnight (?).
This bug should probably be closed.

Comment 5 Pascal Haakmat 2003-01-13 12:37:31 UTC
Please ignore this bugreport, it was a broken version of binutils.


Note You need to log in before you can comment on or make changes to this bug.