Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81719 - AC_CHECK_SIZEOF fails with GCC 3.0.4 (Red Hat 7.2)
Summary: AC_CHECK_SIZEOF fails with GCC 3.0.4 (Red Hat 7.2)
Keywords:
Status: CLOSED DUPLICATE of bug 81721
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autoconf
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 11:49 UTC by Pascal Haakmat
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:09 UTC


Attachments (Terms of Use)

Description Pascal Haakmat 2003-01-13 11:49:42 UTC
Description of problem:
autoconf 2.53 (as distributed with Red Hat 8) may have a bug.

Running autoconf on the following two-line configure.in:

AC_INIT(test, 0)
AC_CHECK_SIZEOF(int, 4)

generates a configure script that fails on gcc 3.0.4 (as distributed
with Red Hat 7.2). config.log has been attached.

Version-Release number of selected component (if applicable):
2.53

How reproducible:
Always

Steps to Reproduce:
1. Create two-line configure.in as described above on a Red Hat 8 system.
2. Run 'autoconf'.
3. Move generated 'configure' script to a Red Hat 7.2 system.
4. Run './configure'.
    
Actual results:
checking size of int... configure: error: cannot compute sizeof (int), 77

Expected results:
checking size of int... 4

Additional info:
--- Example:
$ gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.0.4/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --host=i386-redhat-linux --with-system-zlib
Thread model: posix
gcc version 3.0.4 (Red Hat Linux 7.2 3.0.4-1)
$ ./configure
<output deleted>
checking size of int... configure: error: cannot compute sizeof (int), 77
$ export CC=kgcc
$ kgcc -v
[p@awacs autoconf-bug]$ kgcc -v
Reading specs from
/usr/lib/gcc-lib/i386-glibc21-linux/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
<output deleted>
checking size of int... 4
$

Comment 1 Pascal Haakmat 2003-01-13 11:55:07 UTC

*** This bug has been marked as a duplicate of 81721 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.