Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 817184 - GRUB2 doesn't enable high resolution video mode on boot because unicode.pf2 is nowhere to be found
Summary: GRUB2 doesn't enable high resolution video mode on boot because unicode.pf2 i...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-27 23:17 UTC by Artem S. Tashkinov
Modified: 2012-04-28 00:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-28 00:04:32 UTC


Attachments (Terms of Use)

Description Artem S. Tashkinov 2012-04-27 23:17:36 UTC
Description of problem: GRUB2 doesn't enable high resolution video mode on boot because unicode.pf2 is missing:

if loadfont unicode ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi

$ ls -l /boot/grub2/*.pf2
(nothing)

Version-Release number of selected component (if applicable): grub2-1.99-19.fc17


How reproducible: always


Steps to Reproduce:
1. Install F17
2. Reboot
3.
  
Actual results: GRUB2 at 80x25 text mode


Expected results: GRUB2 at native video mode


Additional info:

$ yum whatprovides '*pf2'

Nothing relevant - just /usr/share/grub/themes/starfield/dejavu.pf2 from the grub2 package itself

Comment 2 Artem S. Tashkinov 2012-04-28 00:04:32 UTC
(In reply to comment #1)

Thank you!

(I hope grub2 will be updated to this version before Fedora 17 gets released).


Note You need to log in before you can comment on or make changes to this bug.