Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81712 - sawfish 1.2 won't compile when gtk-2.2 is installed
Summary: sawfish 1.2 won't compile when gtk-2.2 is installed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: sawfish
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
: 82668 (view as bug list)
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-13 05:37 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-28 23:28:59 UTC


Attachments (Terms of Use)
Patch to allow sawfish 1.2 to compile against gtk-2.2 (deleted)
2003-01-13 05:38 UTC, Nathan G. Grennan
no flags Details
Patch to allow sawfish 1.2 to compile against gtk-2.2 (deleted)
2003-01-13 05:38 UTC, Nathan G. Grennan
no flags Details | Diff

Description Nathan G. Grennan 2003-01-13 05:37:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
In src/gtk-style.c on line 100 is an if statement that says if GTK_MINOR_VERSION
is 2 then do something. That was meant for gtk-1.2 and was made in a time when
gtk-2.2 didn't exist. Since it is only needed by gtk-1.2 the if statement and
the contents inside can just be removed. I did this and was able to compile
sawfish against gtk-2.2. I then made a patch of the change.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install gtk-2.2 from rawhide
2. install sawfish-1.2 source rpm
3. rpmbuild -bb sawfish.spec
    

Actual Results:  errors about font_name and such in gtk-style.c

Expected Results:  no errors and compile to finish

Additional info:

Comment 1 Nathan G. Grennan 2003-01-13 05:38:33 UTC
Created attachment 89331 [details]
Patch to allow sawfish 1.2 to compile against gtk-2.2

Comment 2 Nathan G. Grennan 2003-01-13 05:38:38 UTC
Created attachment 89332 [details]
Patch to allow sawfish 1.2 to compile against gtk-2.2

Comment 3 Havoc Pennington 2003-01-13 05:41:24 UTC
Thanks, good catch.

Comment 4 Nathan G. Grennan 2003-01-13 05:42:46 UTC
Installed rpm with this patch and it works as expected.

Comment 5 Havoc Pennington 2003-01-24 20:21:34 UTC
*** Bug 82668 has been marked as a duplicate of this bug. ***

Comment 6 Havoc Pennington 2003-01-28 23:28:59 UTC
In 1.2-4


Note You need to log in before you can comment on or make changes to this bug.