Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81711 - (text mode) 'space' in full name with no other info causes traceback
Summary: (text mode) 'space' in full name with no other info causes traceback
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-13 05:06 UTC by Need Real Name
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-13 19:58:33 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-01-13 05:06:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
I searched the bugs for something like this and did not find it - apologies if 
this is a dupe.

When asked to enter additional user information, I tabbed through the fields 
(didn't need to add another) and accidentally ended up on the full name 
field.  There I pressed the space bar, then quickly pressed tab to the 'OK' 
button and pressed the space bar again to move forward.  The installer 
promptly issued a traceback error -- and in my haste I didn't try to capture 
it.  However I think this would be easy to reproduce - simply enter no user 
information aside from a single (or more?) space in the full name field, then 
continue as normal.

This is a stock 8.0 install, straight from CD / no kickstart, etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter no information in all fields except 'full name' in 'addiitonal' users 
text window
2. Enter a space (single) in the 'full name' field
3. Press OK
    

Actual Results:  Traceback fault

Expected Results:  Should either ignore it, or prompt me with an error message

Additional info:

Not exactly a big deal, but an uncaught exception nonetheless.

Comment 1 Michael Fulbright 2003-01-13 19:58:33 UTC
This functionality will be moved to the firstboot environment in the next
release.  It will not be an anaconda issue.


Note You need to log in before you can comment on or make changes to this bug.