Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 817093 - Educate sos in the ways of /etc/multipath/
Summary: Educate sos in the ways of /etc/multipath/
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos
Version: 6.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Bryn M. Reeves
QA Contact: David Kutálek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-27 16:42 UTC by Bryn M. Reeves
Modified: 2013-02-21 10:57 UTC (History)
4 users (show)

Fixed In Version: sos-2.2-30.el6
Doc Type: Bug Fix
Doc Text:
Cause: Previous versions of multipath stored path binding data directly in either /etc or the /var/lib directories. Recent versions have moved this to the subdirectory /etc/multipath to allow more consistent SELinux labelling of multipath files. Consequence: Previous versions of sos did not capture the files now stored in this location. Fix: The devicemapper module has been extended to also include the /etc/multipath directory contents. Result: Full bindings data is now captured on hosts using the new directory layout.
Clone Of:
Environment:
Last Closed: 2013-02-21 10:57:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0474 normal SHIPPED_LIVE sos bug fix and enhancement update 2013-02-20 21:06:54 UTC

Description Bryn M. Reeves 2012-04-27 16:42:29 UTC
Description of problem:
The /etc/multipath directory has been made the official blessed home of the bindings file (and possibly other multipath-specific configuration in the future).

Sos should be collecting the whole thing.

Version-Release number of selected component (if applicable):
sos-2.2-*

How reproducible:
100%

Steps to Reproduce:
1. grep -r '\/etc\/multipath' /usr/lib/python-*/site-packages/sos
  
Actual results:
        self.addCopySpec("/etc/multipath.conf")

Expected results:
        self.addCopySpec("/etc/multipath.conf")
        self.addCopySpec("/etc/multipath/")

Additional info:
Also needs fixing upstream.

Comment 1 RHEL Product and Program Management 2012-07-10 06:57:39 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 2 RHEL Product and Program Management 2012-07-11 01:58:25 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 7 errata-xmlrpc 2013-02-21 10:57:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0474.html


Note You need to log in before you can comment on or make changes to this bug.