Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 816855 - headphone/speaker mute cause mute of master channel but do not unmute it again on Intel N10/IHC7 (ALC269)
Summary: headphone/speaker mute cause mute of master channel but do not unmute it agai...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jaroslav Kysela
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 825204
TreeView+ depends on / blocked
 
Reported: 2012-04-27 08:15 UTC by Tomas Pelka
Modified: 2012-05-25 11:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 825204 (view as bug list)
Environment:
Last Closed: 2012-05-25 11:06:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
alsa-info (deleted)
2012-05-04 14:19 UTC, Jiri Koten
no flags Details
alsa-info (deleted)
2012-05-25 09:24 UTC, Jiri Koten
no flags Details

Description Tomas Pelka 2012-04-27 08:15:15 UTC
Description of problem:
When I mute headphone or speaker out via alsamixer master will mute automatically but it will not get unmuted back when I unmute headphone or speaker.

Also when I mute master only I'm not able unmute it back, I have to mute/unmute speaker or headphones again.

Version-Release number of selected component (if applicable):
kernel-2.6.32-262.el6
alsa-lib-1.0.22-3.el6

How reproducible:
100%

Steps to Reproduce:
1. play music
2. mute master via alsa mixer
3. umute

or

1. play music
2. mute speaker or headphones out
3. umute speaker or headphones out
  
Actual results:
no sound

Expected results:
should be unmuted

Additional info:
muting via sound-preferences works fine

Intel N10/IHC7 [8086:27d8] with ALC269

Comment 4 RHEL Product and Program Management 2012-05-03 04:40:35 UTC
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 5 Jiri Koten 2012-05-04 14:19:30 UTC
Created attachment 582131 [details]
alsa-info

Similar problem, mute Master through alsamixer works but unmute not. Pulseaudio volume control still shows muted, sound not audible.

Muting Headphones channel, mutes also Master but unmute leave Master muted.

HW: Realtek ALC889

Comment 10 Tomas Pelka 2012-05-15 06:24:58 UTC
All working now as expected in kernel-2.6.32-270.el6.

Closing as CURRENTRELEASE.

Comment 11 Jiri Koten 2012-05-25 09:24:47 UTC
Created attachment 586809 [details]
alsa-info

Not working for me, same problem as in comment 5.


Note You need to log in before you can comment on or make changes to this bug.