Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81680 - bad source code
Summary: bad source code
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
: 110694 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-12 18:34 UTC by d.binderman
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-03-19 23:05:10 UTC


Attachments (Terms of Use)

Description d.binderman 2003-01-12 18:34:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package autofs-3.1.7-33 from Redhat 8.0

The compiler said

parse_sun.c:467: warning: too few arguments for format

Here is an untested patch to shut up the compiler

*** ./modules/parse_sun.c.old	2003-01-04 14:30:56.000000000 +0000
--- ./modules/parse_sun.c	2003-01-04 14:32:03.000000000 +0000
***************
*** 464,470 ****
      if ( !strncmp(q, "fstype=", 7) ) {
        fstype = alloca(strlen(q+7)+1);
        if ( !fstype ) {
! 	syslog(LOG_ERR, MODPREFIX "alloca: %s");
  	return 1;
        }
        strcpy(fstype, q+7);
--- 464,470 ----
      if ( !strncmp(q, "fstype=", 7) ) {
        fstype = alloca(strlen(q+7)+1);
        if ( !fstype ) {
! 	syslog(LOG_ERR, MODPREFIX "alloca: %s", "");
  	return 1;
        }
        strcpy(fstype, q+7);

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with compiler that checks printf format strings
2.
3.
    

Additional info

Comment 1 Miloslav Trmac 2004-02-05 01:41:05 UTC
*** Bug 110694 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.