Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81657 - Running Kickstart freezes mouse
Summary: Running Kickstart freezes mouse
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-kickstart
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-12 07:35 UTC by Mike DeMicco
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-15 22:55:23 UTC


Attachments (Terms of Use)

Description Mike DeMicco 2003-01-12 07:35:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Selecting Kickstart from the System Tools menu in KDE freezes Microsoft
IntelliMouse Optical USB pointer. Keyboard can still be used. It happens almost
always.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Select Kickstart GUI menu from System Tools
2.
3.
    

Actual Results:  Mouse freezes.Kickstart sometimes comes up, sometimes doesn't.

Expected Results:  Mouse doesn't freeze.

Additional info:

Keyboard can still be used. It happens almost always. No error dialog comes up.
There may be a message in a log file, but I don't know how to access it.

Comment 1 Brent Fox 2003-10-14 01:04:58 UTC
Sorry for not responding to this earlier.  It was misfiled against 'mkkickstart'
instead of 'redhat-config-kickstart'.

I am unable to reproduce this behavior.  To be honest, I don't see how starting
the program could cause the mouse to freeze since redhat-config-kickstart does
not try to probe the mouse.

Try opening a terminal and running 'redhat-config-kickstart' from the command
line.  Does the mouse still lock up?

Comment 2 Mike DeMicco 2003-10-14 02:11:36 UTC
Yes it still occurs, but is not limited to kickstart -- any program that probes
the USB.

Comment 3 Brent Fox 2003-10-14 04:12:06 UTC
Well, that's the funny thing...redhat-config-kickstart doesn't probe for the
mouse at all.

Comment 4 Brent Fox 2003-10-14 23:05:54 UTC
notting: Have you seen any bugs similar to this regarding mouse probing in RHL 8.0?

Comment 5 Bill Nottingham 2003-10-15 02:52:10 UTC
No, I don't recall anything like that.

Comment 6 Brent Fox 2003-10-15 22:55:23 UTC
Well, I don't know how else to proceed here other than to resolve as
'worksforme'.  I'm fairly certain that the Microsoft IntelliMouse optical
cordless works with Red Hat Linux on other machines.  I don't know how to
explain the behavior you are seeing because there is no mouse probing code in
redhat-config-kickstart.


Note You need to log in before you can comment on or make changes to this bug.