Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 816468 - wrong message display in virt-viewer when reconnect guest for multiple monitors testing.
Summary: wrong message display in virt-viewer when reconnect guest for multiple monito...
Keywords:
Status: CLOSED DUPLICATE of bug 816550
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Daniel Berrange
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-26 07:31 UTC by zhe peng
Modified: 2012-05-04 15:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-04 15:42:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description zhe peng 2012-04-26 07:31:08 UTC
Description of problem:
wrong message display in virt-viewer when use --reconnect --wait for multiple monitors testing.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-6.el6.x86_64
libvirt-0.9.10-14.el6.x86_64
qemu-kvm-0.12.1.2-2.267.el6.x86_64
spice-gtk-0.11-8.el6.x86_64
spice-server-0.10.1-5.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1: prepare win guest with spice
2: add two qxl video,and start the guest
3: in guest , install qxl-win driver,config two monitors
4: use virt-viewer to open guest with --reconnect --wait
 #virt-viewer win7_64 --reconnect --wait
5: virt-viewer will open two display
6: in host console shutdown the guest,run
#virsh destroy win7_64
  
Actual results:
the first virt-viewer window show message "Waiting for guest domain to re-start"
the second window show message "Connected to graphic server", this is not make sense


Expected results:
all virt-viewer message should same with first window
"Waiting for guest domain to re-start"

Additional info:

Comment 2 RHEL Product and Program Management 2012-05-03 04:43:08 UTC
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Daniel Berrange 2012-05-04 15:42:41 UTC
The windows should not even have remained visible once the guest shutdown. This is actually the same root cause as bug 816550

*** This bug has been marked as a duplicate of bug 816550 ***


Note You need to log in before you can comment on or make changes to this bug.