Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81627 - hwbrowser crashes upon loading
Summary: hwbrowser crashes upon loading
Keywords:
Status: CLOSED DUPLICATE of bug 74956
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-11 15:27 UTC by Edmund Lam
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:07 UTC


Attachments (Terms of Use)

Description Edmund Lam 2003-01-11 15:27:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021022

Description of problem:
Upon running hwbrowser, a window briefly displays, before disappearing and a
Python error message is printed to standard output/error.

This bug sounds exactly like
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=61917 except it affects Phoebe.

Incidentally, this system (Toshiba Satellite 3000 laptop) has fancy hardware
such as wireless, firewire, usb, smartmedia, pcmcia cards etc etc.

Additional information contains the text/message that was printed to stderr/stdout.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run hwbrowser
2.
3.
    

Actual Results:  After a few seconds, a windows appears, then disappear followed
by a crash.

Expected Results:  hwbrowser shouldn't crash and should display useful information.

Additional info:

[root@localhost root]# hwbrowser                                               
                                                                           
Traceback (most recent call last):                                             
                                                                             
File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?                      
                                                                             
reread_device_type_list ()                                                     
                                                                          File
"/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list     
                                                                        
list.set (iter, 0, hardware.get_category_string (key), 1, key)                 
                                                                          File
"/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string          
                                                                         return
self.type_mapping[key]                                                         
                                                                 KeyError: 20

Comment 1 Brent Fox 2003-01-13 07:00:23 UTC

*** This bug has been marked as a duplicate of 74956 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.