Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81626 - NCHardwareFactory.py:42:getHardwareClass:KeyError: Wireless
Summary: NCHardwareFactory.py:42:getHardwareClass:KeyError: Wireless
Keywords:
Status: CLOSED DUPLICATE of bug 80935
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-11 15:10 UTC by Edmund Lam
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:07 UTC


Attachments (Terms of Use)

Description Edmund Lam 2003-01-11 15:10:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021022

Description of problem:
redhat-config-network crashes on startup and is completely unusable. Possibly
due to me running on a Toshiba Satellite 3000 laptop with builtin wireless card.
See additional information for capture of the error message

Version-Release number of selected component (if applicable):
1.1.86

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-network
2.
3.
    

Actual Results:  program does not start due to a Python exception.

Expected Results:  Program should start and be usable.

Additional info:

Component: redhat-config-network
Version: 1.1.86
Summary: TB
/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareFactory.py:42:getHardwareClass:
KeyError: Wireless

Traceback (most recent call last):
  File "/usr/sbin/neat", line 98, in ?
    window = mainDialog()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 154, in __init__
    self.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 227, in load
    self.loadHardware()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 238, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 389, in getHardwareList
    HWList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 220, in load
    self.updateFromSystem()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 167, in updateFromSystem
    i = self.addHardware(getDeviceType(device))
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 134, in addHardware
    hwc = hwf.getHardwareClass(type)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareFactory.py", line
42, in getHardwareClass
    return self[type][0]
KeyError: Wireless

Local variables in innermost frame:
subtype: None
self: {'Ethernet': {0: <class netconfpkg.NCHWEthernet.HwEthernet at 0x8414104>},
'Modem': {0: <class netconfpkg.NCHWModem.HwModem at 0x81d99dc>}, 'ISDN': {0:
<class netconfpkg.NCHWIsdn.HwIsdn at 0x81dd7c4>}, 'Token Ring': {0: <class
netconfpkg.NCHWTokenring.HwTokenring at 0x83e6bd4>}}
type: Wireless

Comment 1 Harald Hoyer 2003-01-13 11:06:51 UTC

*** This bug has been marked as a duplicate of 80935 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.