Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81624 - "You selected lang/session XYZ but default is 'Default'..."
Summary: "You selected lang/session XYZ but default is 'Default'..."
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: gdm
Version: beta3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-11 14:29 UTC by giulioo
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-13 02:24:17 UTC


Attachments (Terms of Use)

Description giulioo 2003-01-11 14:29:02 UTC
Description of problem:
In gdm login, if you choose another session or language you are told that you
have selected something different than the dafault which is "Default". This is
not much informative about what is the default.
After you select to set a default, successive messages report the actual default
and not the word "Default". This should be the correct behavior from the beginning.

Version-Release number of selected component (if applicable):
gdm-2.4.0.7-14

How reproducible:
always

Comment 1 Havoc Pennington 2003-01-11 16:10:40 UTC
I think it's this way upstream, though George may correct me.

The sessions are:
 - Default: run ~/.Xclients if present else system equivalent
 - Gnome: always run Gnome ignoring .Xclients
 - KDE: always run KDE 

"Default" clearly has the wrong name, but "run ~/.Xclients else system equivalent"
isn't really a reasonable name for it.

Comment 2 Havoc Pennington 2003-01-12 19:27:34 UTC
From George:

The session stuff is completely bogus.  Redhat actually does change what
"default" means by installing a Default session.  The standard installation
just runs the Gnome script.  I really hate the way all this works and would
like some nice common X startup.  If someone has the time to make a spec I'd
be willing to implement it.  It needs to have a common startup script for all
sessions.  Some standard way of running login shell type stuff.  It needs to
have translatable names (and descriptions) and it needs to all be installed
in a common place.  The problems come with stuff like the GNOME chooser
session, but I'm not at all sure how that should be done.
                                                                                 
For language the default is the system default and I think it actually says
that in gdm (may not be in 2.4.0.7 but I think redhat should update to
2.4.1.0 which has many other changes and fixes, and is a stable version
and not a devel version for gnome2.1 because no devel version existed
for 2.1).  I'll make a slightly updated release soon too ...


Comment 3 giulioo 2003-01-12 19:48:16 UTC
>For language the default is the system default and I think it actually says
>that in gdm

It says that literally, something like
"you chose XYZ but the default setting is 'System default'".


Comment 4 Havoc Pennington 2003-01-13 02:24:17 UTC
Moved to http://bugzilla.gnome.org/show_bug.cgi?id=103260 by automated script,
I am going to change the upstream bug slightly though to be 
"unify gnome/kde session setup and default session recording to be sane" or
something.



Note You need to log in before you can comment on or make changes to this bug.