Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81616 - Installer crashes when installing cyrus-sasl-2.1.7-2.i386
Summary: Installer crashes when installing cyrus-sasl-2.1.7-2.i386
Keywords:
Status: CLOSED DUPLICATE of bug 75377
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-11 06:14 UTC by Peter Simon
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:07 UTC


Attachments (Terms of Use)
crashdumpfile (deleted)
2003-01-11 06:17 UTC, Peter Simon
no flags Details

Description Peter Simon 2003-01-11 06:14:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Installing RH8.0 Personal Desktop always crashes on a Fujitsu ergopro pii 350mhz ...

After first crash and crashdumpsave i did a mediacheck which passed with ok. so
i tried it again with standard personal desktop with no additional packets selected.
it crashes on the same cyrus*.rpm

my next step will be to deselct those cyrus packages ...

for details see the crashdump attachment ;)

on this system there was an 7.3 before ... with no problems :))
i do not an update ... install with format ...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install personal desktop
2.normal standard installation ...
3.installer crashes on this system with the cyrus*.rpm
    

Actual Results:  system reboot after saving crashdump

Expected Results:  installation should continue and finish

Additional info:

for more see attachment
here the first lines of the dump :

raceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 719, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 283, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 119, in getFilename
    f = open("/mnt/source/.discinfo")
IOError: [Errno 2] No such file or directory: '/mnt/source/.discinfo'

Local variables in innermost frame:
h: <header object at 0x88e0b90>
self: <image.CdromInstallMethod instance at 0x868ee64>
timer: <timer.Timer instance at 0xaa926dc>

Comment 1 Peter Simon 2003-01-11 06:17:59 UTC
Created attachment 89299 [details]
crashdumpfile

Comment 2 Jeremy Katz 2003-01-11 06:50:36 UTC

*** This bug has been marked as a duplicate of 75377 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.