Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 816140 - Performance: du takes a _lot_ of time to complete
Summary: Performance: du takes a _lot_ of time to complete
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: pre-release
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Vijay Bellur
QA Contact: Sachidananda Urs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-25 10:40 UTC by Sachidananda Urs
Modified: 2014-04-17 11:38 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-17 11:38:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sachidananda Urs 2012-04-25 10:40:57 UTC
Description of problem:

[root@gqac009 nfs-3]# time find pax -type d | wc -l ; time find pax | wc -l
141129

real 524m23.144s
user 0m4.781s
sys 0m39.305s
2215227

real 435m9.818s
user 0m6.625s
sys 0m44.162s
[root@gqac009 nfs-3]#

===========================
  
[root@gqac009 pax]# time du -sh *
64K home
32K lost+found
41G mnt
23M selinux

real 525m1.208s
user 0m3.941s
sys 0m48.601s
[root@gqac009 pax]#


Steps to Reproduce:
run:

/mnt/pax# pax -v -r -w / .

Allow it to run overnight or for a couple of days, this will recursively copy /mnt onto /mnt/pax. Make sure you keep a few GB of data on /mnt (assuming GlusterFS is mounted on /mnt) which is enough to create quite a depth of directory hierarchy.

Setup is a four node distribute on NFS.

Comment 1 Vijay Bellur 2012-05-29 10:09:30 UTC
Deferring this to post RC. Patch available in upstream but a careful evaluation is necessary before that can be backported to release-3.3

Comment 2 Niels de Vos 2014-04-17 11:38:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.